[SOLVED][Windows] gwadj2.dll: %1 is not a valid Win32 application

Just to confirm, my co-worker is in fact seen below in the replies - for anyone hesitant on responding.


I am having issues starting GroupWise Administrative Console today. Error below:




Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Program Files\Novell\GroupWise Server\admin\lib\gwadj2.dll: %1 is not a valid Win32 application at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857) at java.lang.Runtime.loadLibrary0(Runtime.java:870) at java.lang.System.loadLibrary(System.java:1122) at com.novell.gw.api.config.services.GwWindowsServices.<clinit>(GwWindowsServices.java:49) at com.novell.gw.api.config.services.GwServices.getInstance(GwServices.java:70) at com.novell.gw.api.main.GwAdminService.main(GwAdminService.java:156)





I have tried starting the service, as well as manually starting the gwadmin.jar file via command line. It produces the same result.

Command I used is the same command that the service uses:



jre\bin\java.exe -Dlog4j.configuration="file:///C:\Program Files\Novell\GroupWise Server\admin\gwadmin-logging.xml" -DLOGPATH="%PROGRAMDATA%\Novell\Groupwise\gwadmin\logs" -jar gwadmin.jar -auto



(Note: jre\bin\java.exe is IN the GroupWise Server\admin folder, included during installation)


Server Specs:

  • OS: Windows Server 2016, latest updates.
    • JRE 1.8.0_144 (64bit)
    • jre1.8.0_221 (32bit & 64bit)
    • jdk1.8.0_221 (32bit & 64bit)
  • GW: GroupWise Version 2014 R2

What has already been done to try and resolve this?

  • Reinstalled all current JRE / JDK. This resolved a PATH variable issue, however the above error still comes up.
  • We tried uninstalling NICI 32bit (As seen as a solution to a similar but different issue here)
  • We even reinstall groupwise completely.

I would like to point out that even trying to change a users password via ConsoleOne shows no errors but does NOT work either. Not sure if it's related.

This started happening after the server hard crashed due to a BSOD. I am sure there has been some data loss here of course due to the crash, however - I have tried installing GW2014 on a fresh VM in a different location remotely and the result is the EXACT same. This new VM has similar specs to the server mentioned above.

Any one have any ideas?

Parents Reply Children