Configure GroupWise High Availability (GWHA) in 5 easy steps!


written by Peter van der Walt for



Enabling the GWHA component on Linux enables your GroupWise system to automatically restart agents when they stop running for whatever reason. This greatly reduces manual administration and system downtime.

I have been configuring this on all my GroupWise installations on Linux and have only had great experiences with this.

I have found the Novell documentation to be a bit vague, so it took me a day or two to figure out how to actually deploy GWHA - I thus decided to create a article showing how easily it can be deployed, requiring only 5 simple steps!


  1. Install GroupWise Monitor on one of the GroupWise servers

    1. Install and Configure GW Monitor on one server

  • Edit the /etc/init.d/grpwise-ma script and uncomment the MA-OPTIONS line.In the screenshot below, you can see a Sample:

    The modifed /etc/init.d/grpwise-ma script

    Leave the Username as 'gwha', change the password to whatever you want to use, and change the Poll time to how many seconds you want to wait before checking the agents are still running.

  • On all the GroupWise servers to be monitored:-- check /etc/opt/novell/groupwise/gwha.conf
    -- run 'useradd gwha' to create a local user for GWA to run as
    -- run 'passwd gwha' to set the user's password to the one used in step 2.
    -- Yast -> Xinetd -> gwha -> Toggle Status On - to ensure that the GWHA is enabled.

  • Test that the GWHA daemon is listening (netstat -nl | grep 8400)

  • Test by killing the agent's processes and confirm that GWHA restarts the agents

    Do a 'ps -eaf | grep mta' for example, and kill the MTA's process using a 'kill -9 <PID>'

    Do a 'rcgrpwise status' to see if the MTA's status goes "dead" followed by "running" after the GroupWise monitor's poll time passed, it detected the agent as dead and restarted it.


As simple as that! In 5 easy steps you have configured GroupWise High Availability!

If any of the gwpoa, gwmta, gwinter or gwia processes should stop running - the GroupWise monitor will detect the agent status as Dead and issue the start command through the GWHA daemon - in seconds without any operator intervention!


How To-Best Practice
Comment List
  • I would add a couple of troubleshooting steps, as I don't think it's as easy as the article makes it sound.

    If you're MTA or POA does not restart even though you see it in your monitor or agent monitor screen check these things ..

    . When you created your local user , did you spell the name correctly and the password
    . on each individual server that runs your POAs or MTAs does your /etc/opt/novell/groupwise/gwha.conf file have the EXACT (both spelling and case) verbiage between the brackets as the monitor? If your monitor shows PostOffice.Albany and your gwha.conf file has [postoffice.albany], that is NOT going to work.
    . check your /etc/opt/novell/groupwise/gwha.allow file. It must the name of the local user your created (perhaps gwha)
    . check /etc/xinitd.d/gwha on each server hosting a POA and/or MTA. This file tells gwha service on each server containing agents being monitored where the gwha software is. I've seen it be wrong right out of the box. For instance I've seen it pointing to /opt/novell/groupwise/bin/gwha when it should have been /opt/novell/groupwise/agents/bin/gwha.
    . make sure you've started the gwha XINITD service inside of YAST, Network Services, Network Services (xinetd) by toggling it on.

    I find almost all my problems by following these checks.
  • When that happens to me it's usually a new server where I've forgotten to add the "gwha" user (with the correct password) to that server. You might want to double-check that step.
  • I installed GW Montior and I can see all my PO's the MTA and such. I configured the the grpwise-ma file, verified the GWHA is enabled in Yast and ran a ps -aef | grep gwha to verify it was running. I shut down the MTA and it never comes back up.

    OES Linux 2.0.3 x64 SLES 10 sp 3 GW 2012 SP1

    I must have missed something.
  • Thanks for sharing this Article.

    and what if a node/box running a service/role like Post Office(PO) goes offline ? I mean does GWHA also starts the service(e,g PO , IA, MTA) on another node if the primary server for that role goes offline.

    And is it also possible to configure GWHA to make a Load Balancing Cluster of Internet Agents.
  • 1) If you use the SuSEfirewall2, be sure to open port 8400 on every server that hosts agents.
    2) Run the Monitor Agent, if possible, on a server different from your agent servers.
    3) Become familiar with /var/run/novell/groupwise/*.pid files as these directly correlate with the results you see when you run 'rcgrpwise status'. I.e. when you see status "[unused]" on your agents, it means there is no .pid file for that agent, not necessarily that the agent isn't running. Confirm whether an agent is truly running with 'ps -ax | grep gw".
    4) You can also use "rcgrpwise stop ..." to test the auto-restarting of agents; this will gracefully shut down your agent instead of abruptly (kill -9). Then use repeated "rcgrpwise status" to watch for the agent to change to "Running" status.