Modifying GroupWise for Retina Macs

By jlodom

If you have a new Retina MacBook Pro, you may have noticed that the GroupWise client for OS X looks blurry compared to other applications on your system. This is because the GroupWise client for OS X is written in Java, and cannot pick up new Apple technologies without modification.

For the image elements (folders, etc.) we cannot do anything until Novell updates the client themselves. However, for text (and, after all, that's what we care about in e-mail) there is a small change we can make to the application that will give us Retina-quality text right now. This change was first pointed out for other Java applications at Java and Mac retina support >

Here are the steps:

  1. Close down the GroupWise client and open the Terminal application that is in the Utilities folder (/Applications/Utilities/

  • Enter the following command (assuming that you have GroupWise at the top level of your machine's applications folder rather than in any other location such as your home directory's application folder):sudo nano -w /Applications/

  • Enter your OS X admin password.

  • Scroll to the bottom of the text file using the arrow keys. Right above the very last instance of </dict>, paste the following two lines:

  • Type CTRL-X to exit and say yes to saving the file.

  • Log out or restart the MacBook Pro. GroupWise should now have Retina text.

That's all!


How To-Best Practice
Comment List
  • Big improvement. Thanks Johnny and Besposito!
  • Good job on this one Johnny and Besposito. I was tired of the blur.
  • The above fix works with the too.
  • It did not initially work for me when I did it. I found that it wasn't reloading the updated Info.plist file. The way to fix this problem is to force the system to reread the Info.plist file and thereby load Groupwise's new capabilities, which can be done by manually updating the modification date timestamp for the affected programs. To do this, open the Terminal utility (if it isn't already open) and perform the following steps:
    Type the following:

    touch /Applications/

    Press Enter and restart.

    Once I did this I was able to view the properties of the and the checkbox for Open In Low Resolution was unchecked and no longer greyed out. It now opens with the text being much easier to read.

    Thanks for the tip! This is great info.