BIASVAL on mimetype

I'm trying to bias URLs that report their mime type as HTML documents over PDFs and other types.

I've add this to the query and it does not affect the results.

FieldText=BIASVAL{text/html,25}:*/DOCUMENT_KEYVIEW_CONTENTTYPE_STRING

If I use the same field specification with MATCH{text/html} I only get back HTML documents so the field exists and has the values I expect.  But I've not found a way to promote all the HTML and/or demote non-HTML

Any guess what I'm missing?

Parents
  • Have you checked that DOCUMENT_KEYVIEW_CONTENTTYPE_STRING is configured as either MatchType or ParametricType (with ParametricNumericMapping enabled)?

    If it's not you should be getting back the warning:

    <autn:warning>
    BIASVAL must be restricted to MatchType or ParametricNumericMapping fields only. The bias will not occur
    </autn:warning>

    You can check which fields the engine has configured as those types with:

    action=gettagnames&fieldtype=match,parametric

    To verify, pick one document with the right value and try:

    action=query&fieldtext=BIASVAL{text/html,25}:DOCUMENT_KEYVIEW_CONTENTTYPE_STRING&matchreference=<ref>&absweight=true

    action=query&fieldtext=BIASVAL{text/html,1}:DOCUMENT_KEYVIEW_CONTENTTYPE_STRING&matchreference=<ref>&absweight=true

    You should see the <autn:weight> of your one hit change accordingly. If it is changing then the BIASVAL is working correctly and perhaps some other aspect of your results scoring is making you think that it isn't having an effect.

     

    Docs:

    https://www.microfocus.com/documentation/idol/IDOL_12_4/Content_12.4_Documentation/Help/#Actions/Field Specifiers/_IDOL_BIASVAL.htm?Highlight=BIASVAL

Reply
  • Have you checked that DOCUMENT_KEYVIEW_CONTENTTYPE_STRING is configured as either MatchType or ParametricType (with ParametricNumericMapping enabled)?

    If it's not you should be getting back the warning:

    <autn:warning>
    BIASVAL must be restricted to MatchType or ParametricNumericMapping fields only. The bias will not occur
    </autn:warning>

    You can check which fields the engine has configured as those types with:

    action=gettagnames&fieldtype=match,parametric

    To verify, pick one document with the right value and try:

    action=query&fieldtext=BIASVAL{text/html,25}:DOCUMENT_KEYVIEW_CONTENTTYPE_STRING&matchreference=<ref>&absweight=true

    action=query&fieldtext=BIASVAL{text/html,1}:DOCUMENT_KEYVIEW_CONTENTTYPE_STRING&matchreference=<ref>&absweight=true

    You should see the <autn:weight> of your one hit change accordingly. If it is changing then the BIASVAL is working correctly and perhaps some other aspect of your results scoring is making you think that it isn't having an effect.

     

    Docs:

    https://www.microfocus.com/documentation/idol/IDOL_12_4/Content_12.4_Documentation/Help/#Actions/Field Specifiers/_IDOL_BIASVAL.htm?Highlight=BIASVAL

Children
No Data