iprint Appliance V 4.0 iCM re-registration issues. New Issue for us.

Hello All. I have an Iprint Appliance Version 4.0. Our OS Environment is WIndows 10/11.  Most if our clint level is 6.18. Our Iprint Appliance is centralized. For years we have had relatively very little printing issues with this appliance. I have iCM integrated with AD. Recently at one of our highschools, 5 users started having Windows Print dialog freezing issues. Next, the users became unregistered from the iprint server/icm. Usually, when this happens, I just re-register the iprint client with the iprint appliance and all is well IE: ipntcmd -S ServerIP. Unfortunaly, most of these clients WILL NOT re-register with the iprint appliancxe and iCM. Like I sais new issue for us. I tried uninstalling the client, reinstalling the client, upgrading the client. For these workstations NOTHING will work, even weirder, on some of them when I go to uninstall the iprint client, I have to wait hald an hour for the clientto uninstall. 

As a test I reimaged a few of the worstaitons, a few re-registerd but then the problem camer backm again. One re-imaged workstation NO matter what I do, even though I;ve checked the user's print groups and all the usually suspects, no matter how many time I run ipntcmd -S ServerIP her user WILL NOT register with iCM/iprint appliance. Are there any logs you can suggest I check. Like I said this is ALL new, has never been an issue before. 

Any log viewing suggestions?  Anything you can suggest to me? Everyone else at other school sites can print to the centralized printers, and are having no issues with this same Windows 11 Build. And they can register and print perfectly. the Windows 11 OS version I am on with these iprint clients is: Windows 11 22H2 OS Build 22621.2715.