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Knowledge Document: How to renew CA authority on iPrint Appliance 5.x

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Environment

iPrint Appliance 5.x (Upgraded from iPrint Appliance 2.x)

Situation

RPC errors when attempting list printers from the :9443 page after upgrading to iPrint Appliance 5x.  The Appliance at one point was iPrint Appliance 2.x.  Creating a CSR using the certman.sh tool completes without error, but the server certificate is not created. This causes SSL printing to fail.

Cause

The iPrint Appliance upgrade continues the old CA authority which still uses SHA1 signature algorithm.  The causes problems with the port 9443 page listing printers and problems with certman.sh creating a CSR.  

Resolution

Recreate the CA authority

  1. Take a snapshot of the appliance
  2. Go to iManager -> Objects tab -> select the Security container -> delete the CA object (named APPLIANCE_XXXXXXXXX CA)
  3. Run this command within an SSH session
    • ndsconfig upgrade -j
      • Authenticate with:
        • admin.iPrintAppliance
  4. Verify the new CA object is present (see iManager steps above)
  5. Paste the following command into an SSH session:
  1. Accept and Allow the certificates
    • Go to iManager -> iPrint -> Manage Print Manager -> Select the print_manager.iPrintAppliance object.
    • Click the certificate link.
    • Allow and accept all options.
    • Click OK.
  2. Reboot the Appliance

Additional Information

The iPrint Appliance is now running with self-signed certificates.  If a 3rd party certificate is desired, create a new CSR, send the CSR to the external CA, and upload the external certificates using the steps listed in the documentation.
 

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