New Windows10 lockscreen/OES client/AutoAdminLogin problem

This week we encountered a problem when unlocking locked Windows 10 workstations where AutoAdminLogin is enabled for the Windows user. After entering the eDirectory credentials the unlock screen gets stuck and the workstation has to be rebooted. Normal Login is not affected.

The workaround we found to solve this problem is changing the "Unlock Workstation Credentials" in the Advanced Login Settings of the Client to "eDirectory only".

The affected workstations are Windows 10 Pro (64-Bit) version 22H2. Client for Open Enterprise Server 2 SP7 (both IR2 and IR3) is installed.
AutoAdminLogin is enabled (eDirectory prompt, Autologon to Workstation) for use with a generic local Windows user account.
This configuration has worked flawlessly for over a decade. Before the problem occurred both the cumulative Windows update for 22H2 KB5031356 and the current version of Avast Business Security were installed as part of routine maintenance.

I suspect that something in KB5031356 breaks the unlock credential mechanism in the OES client, but did not have the time to investigate further.

Parents
  • Update: after rolling out the above workaround to a number of workstations, the problem is alleviated but unfortunately not resolved.

    • On some workstations changing the setting has no effect. The problem continues to occur whenever the workstation is locked.
    • On all other workstations the workaround fixes the problem only when unlocking the workstation after it has been locked manually ([Windows]+[L]). Th problem still occurs after the workstation was locked automatically by the screensaver.

    P.S.: Disabling or removing Avast does also not fix the Problem.

Reply
  • Update: after rolling out the above workaround to a number of workstations, the problem is alleviated but unfortunately not resolved.

    • On some workstations changing the setting has no effect. The problem continues to occur whenever the workstation is locked.
    • On all other workstations the workaround fixes the problem only when unlocking the workstation after it has been locked manually ([Windows]+[L]). Th problem still occurs after the workstation was locked automatically by the screensaver.

    P.S.: Disabling or removing Avast does also not fix the Problem.

Children
No Data