LVM volume creation

I am trying to create a cluster lvm volumes on OES 24.1. I have tried both ways. Using vlvm as well as NSSMU.

It fails on both accounts with the same error. I have googled the error and found only 1 document. The answer 

in it was useless.

https://support.microfocus.com/kb/doc.php?id=7009516

I checked what it said and all were just fine. 

Here is what I am running and the result

nlvm create linux volume type=btrfs device=xvdh mp=/mnt/btrfscl mntopt=rw lvm name=btrfscl group=vg44 shared ip=10.100.1.88 ncp
Error 23384: Error creating lvm2 group vg44

Thanks for any help

  • I reread the document and finally realized that clvmd is not installed. I think this is a bug that may have happened with the upgrade. I have 5 nodes in the cluster. I started doing some searching in the file system for clvmd and there is none. Checked software install and found nothing. So I decided to see what zipper would find. This does seem interesting I thought. Did something get changed? I am using the 24.1 docs to setup. 

    ricksserv2:~ # zypper in clvmd
    Refreshing service 'nu_novell_com'.
    Loading repository data...
    Reading installed packages...
    'clvmd' not found in package names. Trying capabilities.
    Resolving package dependencies...

    Problem: the installed novell-cluster-services-2.7.1-0.150400.89.5.10.x86_64 obsoletes 'novell-clvmd' provided by the to be installed novell-clvmd-2.02.98-0.150400.14.44.x86_64
    Solution 1: downgrade of novell-cluster-services-2.7.1-0.150400.89.5.10.x86_64 to novell-cluster-services-2.7.0-0.150400.82.3.3.x86_64
    Solution 2: do not ask to install a solvable providing clvmd

    Choose from above solutions by number or cancel [1/2/c/d/?] (c):

    That sure seems strange to me.

  • Curious if anyone is actually using it even. Is it deprecated at this point? Do I need an older version?

  • Suggested Answer

    clvmd is obsoleted by SUSE. Instead use lvm2-lockd and sanlock. Install these 2 packages and you should be able to create cluster lvm volumes.