Support Tip: Conflict When Updating OES2018SP2 or OES2018SP3

1 Likes

Update 9 for OES2018SP2 and Update 4 for OES2018SP2 were released a little over a week ago, this has been posted in another post.  When patching a conflict may be seen:

Problem: edirectory-oes-xdas-instrument-9.1.4-7.3.x86_64 requires libexpat.so.0()(64bit), but this requirement cannot be provided
 uninstallable providers: edirectory-oes-expat-9.2.4.1-1.2.x86_64[nu_novell_com:OES2018-SP3-Pool]
 Solution 1: deinstallation of edirectory-oes-xdas-instrument-9.1.4-7.3.x86_64
 Solution 2: do not install patch:oes2018-SP3-2022-16-1.noarch
 Solution 3: break edirectory-oes-xdas-instrument-9.1.4-7.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):

The short answer is select Solution 1.  If however you are using Sentinal with XDAS instead of CEF eDirectory auditing, either switch eDirectory to use CEF auditing or hold off on the patch.  This issue is being tracked in this KB article, as additional updates are received they will be posted:

https://portal.microfocus.com/s/article/KM000009328?language=en_US

Labels:

Support Tip
Comment List
Anonymous
  • Interestingly the GUI Package Updater (at least in a couple instances) does not give that option, just fails


    The work around that was to open YAST, Software Management, search for xdas to find the instrument.  Right click on edirectory-oes-xdas-instrument and select delete.  Leave the others in place, as that logging is somehow still a dependency for eDirectory, at least at this point.   Click Apply and then Finish.
    Return to Package Updater (Under System Tools) and patch as normal.

    ________________________

    Andy of KonecnyConsulting.ca in Toronto
    Please use the "Like" and/or "Verified Answers" as appropriate as that helps us all.

Related Discussions
Recommended