Knowledge Document: MozillaFirefox-branding-SLE conflict when patching OES2023

0 Likes

Environment

Open Enterprise Server 2023 (OES 2023)
 

Situation

The following conflict is encountered when patching OES2023:

# zypper patch
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...
2 Problems:
Problem: the installed MozillaFirefox-branding-SLE-91-150200.9.7.1.x86_64 requires 'MozillaFirefox < 92', but this requirement cannot be provided
Problem: the installed MozillaFirefox-branding-SLE-91-150200.9.7.1.x86_64 requires 'MozillaFirefox < 92', but this requirement cannot be provided
 
Problem: the installed MozillaFirefox-branding-SLE-91-150200.9.7.1.x86_64 requires 'MozillaFirefox < 92', but this requirement cannot be provided
Solution 1: Following actions will be done:
  deinstallation of MozillaFirefox-branding-SLE-91-150200.9.7.1.x86_64
  deinstallation of MozillaFirefox-translations-common-91.13.0-150200.152.56.2.x86_64
  deinstallation of yast2-oes-registration-3.3.0-150400.4.3.3.noarch
  deinstallation of patterns-oes-novell-yast2-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-base-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-microfocus-umc-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-cifs-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-edirectory-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-imanager-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-lum-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-ncpserver-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-nrm-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-nss-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-nssad-12.4.0-150400.15.3.x86_64
  deinstallation of patterns-oes-novell-sms-12.4.0-150400.15.3.x86_64
  deinstallation of suseRegister-oes-1.4-1.150400.41.1.noarch
Solution 2: do not install patch:SUSE-SLE-Product-SLES-15-SP4-LTSS-2023-4928-1.noarch
Solution 3: break MozillaFirefox-branding-SLE-91-150200.9.7.1.x86_64 by ignoring some of its dependencies
 

Cause

An updated MozillaFirefox-branding-SLE is needed, but not available.  This is likely caused by the OES2023-SLE-Module-Desktop-Applications15-SP4-Pool and OES2023-SLE-Module-Desktop-Applications15-SP4-Updates repositories not being enabled.
 

Resolution

  1. Enter "c" for cancel.
  2. Enable the OES2023-SLE-Module-Desktop-Applications15-SP4-Pool and OES2023-SLE-Module-Desktop-Applications15-SP4-Updates repositories with these commands:
    zypper mr -e OES2023-SLE-Module-Desktop-Applications15-SP4-Pool
    zypper mr -e OES2023-SLE-Module-Desktop-Applications15-SP4-Updates
  3. Attempt to patch again.

Access article on support portal


 

Labels:

Knowledge Docs
Comment List
Related
Recommended