This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Micro Focus Retain: (Index) Out of disk space warning

Your current index size is 121.2 GB and your available disk space is 122.25 GB for the /var/opt/beginfinite/retain/index path.

We have a Retain virtual server.  I know how to increase the virtual server hard drive but what do I need to do to increase the disk?

How do I check what is the current disk size, so that I can increase the correct HDD.  From what I can see, we currently have 3 HDD.

Parents
  • Suggested Answer

    Your Retain index directory is located at /var/opt/beginfinite/retain/index/
    We hope that the person that installed Retain allocated a separate disk for Retain.
    Run this command to find out how your Linux OS disks were allocated:
    df -Th
    Did that person make any part of the above path, mount to a separate disk than what was used for the Linux OS root partition at / ?
    Like    Filesystem: /dev/sdb1 , Mounted on: /var
    Here is SuSE's SLES 12 chapter on resizing filesystems:
    https://documentation.suse.com/sles/12-SP5/html/SLES-all/cha-resize-fs.html

    ________________________

    Ed Hanley
    Lead Solutions Consultant
    Although I am an OpenText employee, I am speaking for myself and not for OpenText.
    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

  • This is the filesystem that I want to increase /dev/mapper/beginfinite-opt  xfs  750G 564G 187G 76% /var/opt

    What Is the command?  Is it ...

    sudo xfs_growfs -d /dev/mapper/beginfinite-opt

  • Reading the SuSE section titled "2.4 Changing the Size of an XFS File System" seems to use the /var/opt (Mounted on) instead of the /dev/... (Filesystem) that you are suggesting.  Maybe the command should be:
    sudo xfs_growfs -d /var/opt

    ________________________

    Ed Hanley
    Lead Solutions Consultant
    Although I am an OpenText employee, I am speaking for myself and not for OpenText.
    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

  • If I take a snapshot before I increase the drive, can I revert it back to that snapshot if there is any issues or will that cause issues on retain?

  • Suggested Answer

    Nancy - do you have the databases and indexes on the same server?  If so, then this won't be an issue.  Bring Retain down, take a snapshot of the entire system before the expand.  If the dbs and indexes are not part of the snapshot, then make sure to disable archiving and deletion jobs before the expand.  The less change to the system before or after, the better it will be.  Once you do the expand you can verify that all is well with the system and if so, re-enable archiving and deletion jobs.  -  Pam

  • data size unchanged, skipped when I run sudo xfs_growfs -d /var/opt
     

    Not sure why?  df -Th  results below.
    Filesystem                  Type      Size  Used Avail Use% Mounted on
    devtmpfs                    devtmpfs  4.0M     0  4.0M   0% /dev
    tmpfs                       tmpfs     9.7G   16K  9.7G   1% /dev/shm
    tmpfs                       tmpfs     3.9G  9.2M  3.9G   1% /run
    tmpfs                       tmpfs     4.0M     0  4.0M   0% /sys/fs/cgroup
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /.snapshots
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /boot/grub2/i386-pc
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /root
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /srv
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /opt
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /tmp
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /usr/local
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /boot/grub2/x86_64-efi
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /var
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /home
    /dev/mapper/database-mysql  xfs       100G   45G   56G  45% /var/lib/mysql
    /dev/mapper/beginfinite-opt xfs       750G  566G  185G  76% /var/opt
    tmpfs                       tmpfs     2.0G   60K  2.0G   1% /run/user/468
    tmpfs                       tmpfs     2.0G   40K  2.0G   1% /run/user/0

    Am I running the correct command?

Reply
  • data size unchanged, skipped when I run sudo xfs_growfs -d /var/opt
     

    Not sure why?  df -Th  results below.
    Filesystem                  Type      Size  Used Avail Use% Mounted on
    devtmpfs                    devtmpfs  4.0M     0  4.0M   0% /dev
    tmpfs                       tmpfs     9.7G   16K  9.7G   1% /dev/shm
    tmpfs                       tmpfs     3.9G  9.2M  3.9G   1% /run
    tmpfs                       tmpfs     4.0M     0  4.0M   0% /sys/fs/cgroup
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /.snapshots
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /boot/grub2/i386-pc
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /root
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /srv
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /opt
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /tmp
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /usr/local
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /boot/grub2/x86_64-efi
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /var
    /dev/mapper/system-root     btrfs      61G   19G   40G  32% /home
    /dev/mapper/database-mysql  xfs       100G   45G   56G  45% /var/lib/mysql
    /dev/mapper/beginfinite-opt xfs       750G  566G  185G  76% /var/opt
    tmpfs                       tmpfs     2.0G   60K  2.0G   1% /run/user/468
    tmpfs                       tmpfs     2.0G   40K  2.0G   1% /run/user/0

    Am I running the correct command?

Children