This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Storage Manager error: Times out while waiting for a database connection to become available in the connection pool.

Engine running on OES2018sp3, Storage manager 5.3, Admin console  Broke from one day to the next.  Does not manage home directories.

I checked the firewall on engine server and port 3009 is open.  Also tried shutting down the firewall and still same error.

Using nsmengine-config, I try to stop the service and it hangs and fails.  I am able to start the service and it shows as running but still get the errors.

Top shows the nsmengined process running at 100%Server has 16GB memory and 13GB free.  no space issues on the system partition.

Parents Reply Children
  • Yes to both.  Incident #02541637 .  VM has 4 CPU.  What I did last night as a work around:
    I edited the nsmengine.conf file. In the <ConnectionPool> section, I increased the value from 30 to 130 and restarted the engine. The Admin console then started fine and I was able to manage home directories again. I would still like to talk to someone from Condrey to discuss what happened and what an appropriate value is for the connection pool. Top is also reporting normal utilization and namengined thread is no longer running at 100%