LMP Not Processing - HPECM and SharePoint 2013

I've setup simple LMP's for testing. The first is configured to look at the Date last modified. If that date is older than one day archive the record. Then I went to the list on the site, under the library tab, settings, HPECM drop down. I selected the LMO option, then added my LMP (Older then one day). This will immediately kick off and process any records older than a day. WORKS GREAT.

 If I place records in this list today, then wait for a couple of days... it will not process the records. If I make any modifications to the properties of that record in SharePoint, it will run the LMP and process that record but nothing else in that list.

Is anyone else having this issue?

  • Hi Jim, 

    Looks like we already have an official case logged for this.   Happy to offer some advice via this channel whilst we investigate internally.

    Do you have any other LMP failures?  for example immediate management or another LMP?

    Have you tried creating your own LMP that essentially does the same thing as the one you are experiencing difficulty with? (just in case our built LMP doesn't work)

    Do you notice any LMP maintenance job failures in your job queue? 




  • I'm using three LMP's. Two are custom based on "Date Modified" and the other on a custom column called "Date Last Viewed". The last one is the Archive Immediatly. This is working fine, but it has no time based on it.

  • Hi Jim, 

    I ran a test on this on monday and all worked as it should in my test environment.

    I have checked the case you have logged with MF and it appears you are working with R&D on this one,  you have a test binary to provide some additional logging information for us?

    Once R&D have that information it should allows us to see what is happening here.



  • Verified Answer

    I had created the LMP's on the local site configuration. I removed them from there and re-created them in the default site collection. At this time it is working. Unable to duplicate the problem.

  • I found the problem. At one point I had gone into SQL to remove jobs that were pending. I took a shortcut and removed all jobs. When doing this it removes the reoccurring jobs as well.
Reply Children
No Data