Journal Emails using SMTP

We created two SMTP servers and two origins to process the emails from these servers. This was completed a few months ago. This process works very well and last month alone we processed over 800k emails into CM 9.1.

I was working with the Exchange team a few days ago and they brought to my attention that they have emails backing up in the system. We found that any email that is over 50MB is not being accepted by our SMTP server. When these emails are being sent to the SMTP server,  Exchange is getting an error - Recipients:;3;2;[{LRT=};{LED=400 4.4.7 The server responded with 550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route....

In my SMTP settings, I have all message limits unchecked (disabled). The Exchange team tells me that all message limits have been disabled for this journal account. The Exchange team is convinced this is a CM problem, but the messages are not making it to the drop folder on the SMTP server. My thought is that if the message is not there in the drop folder, it is an SMTP or Exchange issue and not CM.

I don't know (or have access to) Exchange servers configuration. SMTP is very simple and I don't see any configuration that could be causing this. Does SMTP have message size limits in general? I've tried to go back and set the limits to 2 GB. This didn't seem to make any difference. It could be a group policy causing this, but I wouldn't think that the SMTP server would even see it if that were the case.

  • Verified Answer

    After going back to our Exchange team we found the problem. The messages were getting caught up via the send connectors in Exchange. They had to increase the size limit restrictions. Then we implemented a custom send connector. The send connector has a custom size limit of 100MB.

    After this was completed, we started receiving all emails with nothing backup up in Exchange.


    I found that after removing the check from the "Limit Message Size" in the properties box the SMTP server has no maximum size limits.