TRIMWatcher error with Offline Records

Running 7.10.1132 with Office 2007 on Windows XP (SP3)


I have encountered an error whenever I attempt to access Offline Records - 'An error occurred accessing the repository for Offline Records.  The server threw an exception. (#80010105)(Is trimwatcher registered?)


Since this problem started, I have found that Setup Info does not respond at all, unless I terminate the TRIMWatcher process (through Task Manager).  After I do this, I am only able to see a restricted set of information (Software Versions, Working Folder, Network Connections, Client Object Cache Settings).


I have also noticed that checking in a new version to an existing record sometimes freezes that instance of TRIM until TRIMWatcher is terminated.


It was suggested that this problem was caused by my Offline Records being set to a location that was not on a Networked drive (it had been set to a location on D:).  However, after having this changed the problem still occurs.


Is this the sort of issue that requires a re-install of TRIM, or is there another setting I should be looking at?

  • We are getting this error.


    In some instances, killing TRIMwatcher works, in others it does not.


    Offline records on a private network drive.


    Any advice would be appreciated.


    TRIM 7.1 build 1150

  • We just sorted this out..


    1. In TRIM 7 Check-in ( ALT F1) all documents
    2. Backup Offline records (c:\My Documents\Offline Records (DBID))
    3. Delete the contents of  offline records c:\Documents\Offline Records (DBID)
    4. Un-install 7.1
    5. Delete the contents of C:\Documents and Settings\username\Application Data\Hewlett-Packard\HP TRIM\DBID\
    6. Delete  C:\Documents and Settings\username\Application Data\Tower Software if it exists
    7. Install TRIM 7.1
    8. Open TRIM 7.1 and go to offline records (F8) to ensure the fix has worked

    If this didn't work we installed TRIM 6 again, unistalled it manually and then followed the steps above again.

    So far its worked for us 80% of time without having to install 6 again.


    Option 2 - If other users can use TRIM on that machine without any problems then you could just delete the users profile from the machine. Just don't forget to backup their data or they'll be very upset.



  • A quicker solution can work if the issue is simply a corrupted .dat file.


    1)  Get the checked out records back into TRIM.

    2)  Clear OfflineRecords.dat so it contains just:

    <?xml version="1.0" encoding="utf-8"?>
    <!--comment:Offline Documents File-->
    <OfflineDocuments version="71" lastDocumentId="0"/>


    3)  Open Offline Records in the client and F6 to force a refresh of the .dat file




  • There is a known issue in TRIM 7.1 that causes that error message. Perhaps this applies to your site:


    The problem exhibits when using the %USERNAME% variable in the registry key HKEY_CURRENT_USER\Software\Hewlett-Packard\HP TRIM\DataPaths\TopDrawerDataPath.


    When using the %USERNAME% variable in this key, the other issue that happens nearly 100% of the time is that users are unable to go to Help - Setup Information in the TRIM client, as this causes the TRIM client to crash and produce dump files.


    In our testing there was a link between the length of the user name and the occurrence of the error, i.e. For short user names (e.g. less than 10 characters - not sure of the exact threshold here) there were no errors, but for longer user names we could reliably reproduce the error.


    The workaround is to explicitly specify the user name in the registry key rather than using the %USERNAME% variable.


    QCCR2D44302 - When trying to right-click and edit documents in TRIM, some users receive errors such as "An error occurred accessing the repository for offline records. The server threw an exception. #80010105 (Is trimwatcher registered?)" (Fixed in


  • --------------------------------------------------------------------------------
    Adam_Ledwos wrote:

    .....and broken again in 7.21.3519




    QCCR2D44937 - When trying to right-click and edit documents in TRIM, some users receive errors such as "An error occurred accessing the repository for offline records. The server threw an exception. #80010105 (Is trimwatcher registered?)"


    It's important to understand that HP is always concurrently developing against more than one release. When the issue above was identified in 7.1, a CR was raised to correct it in 7.1. Another CR was raised to fix it in 7.2. At this stage the fix hasn't been included in a 7.2 release yet.


    So it hasn't "broken again" just hasn't been  included in a 7.2 release yet :-)


    Naturally if this is what's causing you an issue, the workaround is to replace the variable with the actual user name. This could be scripted at logon, for example.

  • TRIM 7.1.0 1157 x64bit, Windows 7, Office 2010 x64bit


    One of my clients is getting a similar error but not exactly the same. Can you tell me if the bug also relates to this error, and if not do you have any ideas how to resolve this one?


    "An error occurred accessing the repository for Offline Records. Library not registered (#8002801d) (Is trimwatcher registered?)"


    Error occurs when accessing set up info and when attempting to edit records. A side issue is that the Office integration cannot be enabled.


    any advice gladly received





  • Hi Jane,


    It's hard to say. We don't have any record of that particular error happening before, but then it's not often people use 64-bit TRIM and 64-bit MS Office on a client PC either. The behaviour sounds pretty similar to that mentioned above, so I suggest you check the registry keys for data paths on an affected user's machine to see if they're using the %USERNAME% variable, e.g:


    HKEY_CURRENT_USER\Software\Hewlett-Packard\HP TRIM\DataPaths\TopDrawerDataPath


    If not, try re-registering trimsdk.dll on the machine to see if that makes any difference (just a hunch - make sure you run a command prompt using the "Run as administraotr" option). E.g:


    regsvr32 "C:\Program Files\Hewlett-Packard\HP TRIM\trimsdk.dll"

  • Hi Neil,


    Thanks for your response. We actually managed to resolve the error by reinstalling TRIM. I'm guessing something must have gone awry with the initial install.



  • Had a client experiencing the same issue (TRIM 7.31) and in our case both the 64 and 32 bit HP TRIM were installed.  The error was consistently occurring on a small handful of 32 bit clients although other users had no issues when using the same PC.


    Launching 64 TDesktop resolved the issue. On further analysis, it appears the 32 bit TDesktop/TRIMwatcher.exe was not initializing/creating Desktop.INI or the values were incorrect under user offline records. Manually creating the file destkop.ini under user offline records resolved the issues by   we copying destkop.ini from a user profile that was working correctly to the affected user's offline records location and this appears to resolve the issue.  Note, make sure TRIMWatcher and TDesktop are not running on task manager when copying desktop.ini.


    Sample desktop.ini value

    iconfile=C:\Program Files\Hewlett-Packard\HP TRIM\tsjocx.dll