Invalid language type, English in IDOL query log

Hi all,

 

I'm coming back to working with RM8 after working with TRIM a while back, and have everything working on a VM aside from the IDOL content search. No content searches are returned and I see the following in the query.log file.

 

19/06/2014 15:14:49 [6] Error: Invalid language type, English. Reverting to default.

 

The lanuguae settings in the TRIM IDOL Service.cfg file are as follows.

 

[LanguageTypes]
LangDetectUTF8=TRUE
DefaultLanguageType=englishUTF8
DefaultEncoding=UTF8
LanguageDirectory=..\shared\langfiles
GenericStemming=true
GenericTransliteration=true
0=english

Has anybody seen this error before?

 

Incidentially, is there any way to query IDOL directly in RM8 given I can't query unencrypted via the browser?

 

Many thanks,

Neil

Parents
  • Havn't come across that one before.

     

    What language is your TRIM client set to?

  • The language error shows up all the time, just ignore it.

    IDOL will be failing to return results for another reason, so don't waste time figuring this one out.

     

    1. Did you complete a reindex?

    2. What version of RM8?

    3. When you added the Content Index in the TES, did the test connection to the IDOL service succeed?

     

  • Hi,
    Thanks for confirmation on the language error. To answer your questions...

    1. Did you complete a reindex? Yes - twice and it appeared successful both times

    2. What version of RM8? 8, build 0.0.6335

    3. When you added the Content Index in the TES, did the test connection to the IDOL service succeed? Yes, the test connection button shows as succeeded

     

    I'm a little confused as to how I troubleshoot this against IDOL. I can't check the userlist or similar to see if user's have been added to IDOL for example.

     

    Many thanks,

    Neil

     

  • From the DIH, the re-index looks good.

    20/06/2014 12:02:34 [6] Normal: Index connection granted to: 127.0.0.1
    20/06/2014 12:02:34 [6] Normal: Streamed 52.10 kB (53349 bytes) to disk in 0.00 secs. Rate 29296.88 kB/s.
    20/06/2014 12:02:34 [6] Normal: Index Queue Command: /DREADDDATA?
    20/06/2014 12:02:34 [2] Normal: Sending command 5 to engine 1 in group 1: /DREADDDATA?&dihmodseed=0&dihcid=1&dihnchildren=2&
    20/06/2014 12:02:34 [1] Normal: Sending command 5 to engine 0 in group 0: /DREADDDATA?&dihmodseed=0&dihcid=0&dihnchildren=2&
    20/06/2014 12:02:34 [2] Normal: Time to send command to engine 1: 0.01 secs.
    20/06/2014 12:02:34 [2] Normal: ChildID=5 IndexID=5 for engine 1, cmd /DREADDDATA?&dihmodseed=0&dihcid=1&dihnchildren=2&
    20/06/2014 12:02:34 [1] Normal: Time to send command to engine 0: 0.01 secs.
    20/06/2014 12:02:34 [1] Normal: ChildID=5 IndexID=5 for engine 0, cmd /DREADDDATA?&dihmodseed=0&dihcid=0&dihnchildren=2&
    20/06/2014 12:10:22 [4] Normal: All Engines have completed job with index 5, took 0s.

    Many thanks,
    Neil
  • From the DIH, the re-index looks good.

    20/06/2014 12:02:34 [6] Normal: Index connection granted to: 127.0.0.1
    20/06/2014 12:02:34 [6] Normal: Streamed 52.10 kB (53349 bytes) to disk in 0.00 secs. Rate 29296.88 kB/s.
    20/06/2014 12:02:34 [6] Normal: Index Queue Command: /DREADDDATA?
    20/06/2014 12:02:34 [2] Normal: Sending command 5 to engine 1 in group 1: /DREADDDATA?&dihmodseed=0&dihcid=1&dihnchildren=2&
    20/06/2014 12:02:34 [1] Normal: Sending command 5 to engine 0 in group 0: /DREADDDATA?&dihmodseed=0&dihcid=0&dihnchildren=2&
    20/06/2014 12:02:34 [2] Normal: Time to send command to engine 1: 0.01 secs.
    20/06/2014 12:02:34 [2] Normal: ChildID=5 IndexID=5 for engine 1, cmd /DREADDDATA?&dihmodseed=0&dihcid=1&dihnchildren=2&
    20/06/2014 12:02:34 [1] Normal: Time to send command to engine 0: 0.01 secs.
    20/06/2014 12:02:34 [1] Normal: ChildID=5 IndexID=5 for engine 0, cmd /DREADDDATA?&dihmodseed=0&dihcid=0&dihnchildren=2&
    20/06/2014 12:10:22 [4] Normal: All Engines have completed job with index 5, took 0s.

    Many thanks,
    Neil
  • From the DIH, the re-index looks good.

    20/06/2014 12:02:34 [6] Normal: Index connection granted to: 127.0.0.1
    20/06/2014 12:02:34 [6] Normal: Streamed 52.10 kB (53349 bytes) to disk in 0.00 secs. Rate 29296.88 kB/s.
    20/06/2014 12:02:34 [6] Normal: Index Queue Command: /DREADDDATA?
    20/06/2014 12:02:34 [2] Normal: Sending command 5 to engine 1 in group 1: /DREADDDATA?&dihmodseed=0&dihcid=1&dihnchildren=2&
    20/06/2014 12:02:34 [1] Normal: Sending command 5 to engine 0 in group 0: /DREADDDATA?&dihmodseed=0&dihcid=0&dihnchildren=2&
    20/06/2014 12:02:34 [2] Normal: Time to send command to engine 1: 0.01 secs.
    20/06/2014 12:02:34 [2] Normal: ChildID=5 IndexID=5 for engine 1, cmd /DREADDDATA?&dihmodseed=0&dihcid=1&dihnchildren=2&
    20/06/2014 12:02:34 [1] Normal: Time to send command to engine 0: 0.01 secs.
    20/06/2014 12:02:34 [1] Normal: ChildID=5 IndexID=5 for engine 0, cmd /DREADDDATA?&dihmodseed=0&dihcid=0&dihnchildren=2&
    20/06/2014 12:10:22 [4] Normal: All Engines have completed job with index 5, took 0s.

    Many thanks,
    Neil
  • Check the Status folder in the IDOL Content Service directories and see if there are any cmd/dat files there?

     

    Did you run the reindex as a user with admin permissions and full security?

     

    Try restarting the IDOL services by stopping the Content services first and then the main IDOL service.

    Wait for all the processes to stop in task manager before starting them in the same order. (Start content services first)

     

    Once they are all restarted, restart the TRIM Workgroup Service.

     

    If you have more than one Workgroup Server, you need to make sure that the IDOL properties in the TES point to the server name instead of 'localhost' too.

     

     

Reply
  • Check the Status folder in the IDOL Content Service directories and see if there are any cmd/dat files there?

     

    Did you run the reindex as a user with admin permissions and full security?

     

    Try restarting the IDOL services by stopping the Content services first and then the main IDOL service.

    Wait for all the processes to stop in task manager before starting them in the same order. (Start content services first)

     

    Once they are all restarted, restart the TRIM Workgroup Service.

     

    If you have more than one Workgroup Server, you need to make sure that the IDOL properties in the TES point to the server name instead of 'localhost' too.

     

     

Children
  • If your content searches are not working - this is message is not the problem. The message is caused by an setting in the HPRM IDOL installation - whenever a search is issued from HP Records Manager, it includes a parameter 'languagetype=English' in the query string. Because of the way that language types are configured in the IDOL OEM included with HPRM, this would generate the following error:

     

    Error: Invalid language type, English. Reverting to default.

     

    The error message can be ignored the search will still complete. This issue will be adressed in a new release of HPRM. So if your content searches are not working, you need to check further in the IDOL logs.

     

    There is a possible workaround - to remove the message, but please ensure that you test this will your release of HPRM first - in all the IDOL configuration files is the Language section make the following changes:

     

    DefaultLanguageType=english
    Encodings=UTF8:english