Is the VM Explorer 7.1.001 supported on Windows 2016 1803 Core ?

Hi, 

as of right now I am running a VM Explorer 7.1.001 as a VM on ESXI 6.7 on a Windows 7 .  I know it's not supported, so I want to migrate to a Windows Server 2016. My question is will I be able to install the VM Explorer 7.1.001 on a Windows Server 2016 1803 Core ? 

Has anyone done something like that. In the official documentation it's stated that it supported on Windows Server 2016 but nothing more. 

Thank you in advance. 

Alex