VM Backup error after maintenance

We recently performed some maintenance on an ESXi cluster we backup using VM Explorer 6.3. A couple of VM's were vMotioned during the maintenance, and ESXi was patched on the whole cluster. All the backups are working except for two VM's that are reporting an error I've never seen before;

Failed: Unable to find a virtual disk which match with the snapshot information <servername>

Nothing else is logged, but the backup just fails. All other VM's in the cluster backup fine. There aren't any outstanding snapshots on the VM's, I've tried removing and re-adding them to the task too. No change. Any ideas?

  • Anyone have any ideas? Still have this problem on the same two servers. Every night, exactly the same error. Can't find any other threads that match, and search shows nothing.

  • The VM Explorer Logs (in C:\ProgramData\Trilead\VMX\log) and the ESXi hostd should help you to analyze what causes this issue. In case you do not get any further by doing so, please open a support case and we will be happy to help you.

  • Have you been able to resolve this issue?

    We face this problem with all of our Windows VMs.

  • I encountered this issue after upgrading some hosts to the latest 6.7U3 release (17167734).  If anyone else is experiencing this issue check the auth log (/var/log/auth.log) on your host, I was receiving:

    2020-12-17T13:30:19Z sshd[2304704]: Unable to negotiate with a.b.c.d port 59450: no matching key exchange method found. Their offer: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1 [preauth]

    So the error is due to an out of date SSH library being used in VM Explorer.  The SSHD config didn't have an existing KexAlgorithms option so I added the following line to the config file and restarted SSHD:

    KexAlgorithms curve25519-sha256[AT SIGN]libssh.org,ecdh-sha2-nistp521,ecdh-sha2-nistp384,ecdh-sha2-nistp256,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

    * NOTE: Replace "[AT SIGN]" with an "@" in the first option above - apparently the forum interpreted it as an email address and modified the content

    If you already have an existing KexAlgorithms option then add ",diffie-hellman-group14-sha1" to the end and restart SSHD.

    You can restart SSHD with:

    /etc/init.d/SSH restart

  • Hi

    We're experiencing this very same problem with ESXi 6.7 with the same build number. What config file are you referencing that needs editing - on ESXi or VMExplorer? Our VMExplorer host is Windows.

    Thanks a lot
  • Verified Answer

    On  your ESXi server, you'll need to edit /etc/ssh/sshd_config and add the following line anywhere in the file:

    KexAlgorithms ecdh-sha2-nistp521,ecdh-sha2-nistp384,ecdh-sha2-nistp256,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

    Then restart sshd with:

    /etc/init.d/SSH restart

  • Nailed it. Thanks a lot. I was looking for the string in the sshd_config file, but didn't realise you needed to add the entire thing. After restarting SSH, VMExplorer could then connect.

     

  • I ran into this issue with ESXi 7.0u2 today.  This thread got me started in the right direction, but it seems that even more has changed with ESXi 7.  I hope this helps others when upgrading to ESXI 7 to get /etc/ssh/sshd_config working with VM Explorer:

    In addition to modifying the "KexAlgorithms" line to add diffie-hellman-group14-sha1, 

    On the "HostKeyAlgorithms" line, add ",ssh-rsa,ssh-dss"

    On the "MACs" line, add ",hmac-sha1-96,hmac-sha1,hmac-md5-96"

    (Note that VM Explorer 7.1.3 also still offers "hmac-md5," but when I tried to add that one to ESXi 7, it errored out saying unsupported MAC).

    After making all these changes, restart sshd.