This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Chrome_elf.dll unable load

Hi All

    I use mfdc 20.9 to try using snapshot chrome ( version 90, it should be latest version) on win7 x64 sp1

then it was been generate and I place it to win10 (2004) to testing....

it show chrome_elf.dll unable to load.....

who had experience to teach me the reason and fix method ??




  • Most likely the snapshot was not taken on a clean machine but here are some general thoughts...

    1. Always perform the Snapshot on a Clean Machine.  In most cases nothing more than the OS and MFDC
    2. Consider using the "Monitor Install" Feature in MFDC 20.x instead of the capture method, especially if having difficulty with a snapshot.  Each methodology has advantages and perhaps if one method does not work, then try the other.
    3. Try using the Professionally Created Packages as a base when possible.   Modify them to suit your needs.  Example - Use the Chrome Instructions to Add a Language to the virtual chrome as well as other changes, then "Merge the Snapshot" back to the base.

    To your specific question about that error, I've never heard of it but it would be very difficult to troubleshoot a failed snapshot.  Most likely there are missing DLLs, Missing Registry Entries, etc... 

    The simplest fix would likely to update the existing professional builds, versus trying to build your own.  The technical skill level is much lower.

    Also some basic troubleshooting.....

    • Did the Virtual App run on the Same Machine on which it was built while the original software was still installed? (Win7 SP1 with Chrome on the machine as a result of the virtual app build?)
    • Did the Virtual App run on the Same Machine when it was reverted to its clean state? This would be the VM reverted to a clean state w/o Chrome.
    • Does the Virtual App run on Other machines?  If not, there could be missing dependencies that need to be added, but this is minimized with a clean install.  If the Base machine and target machine vary in some ways such as 32bit vs 64bit, there may need to be tweaked to the virtual app.  Win7 vs Win10...Does the App install differently for different operating systems and perhaps make some different changes?  If there is an issue going between Architecture or OS, consider building a virtual app that is specific.  While it may be possible to tweak the Virtual App to cross over in cases where there are differences, this is added complexity that may require building snapshots across operating different environments and merging which is highly complex.

    But my primary recommendation would be to use start with the professional build and make sure it works.  Then modify that build to include what you need such as new language files or defaults.  This is far less complex.

    As far as creating one's own snapshot, there is not normally anything specific to "Chrome" to do this.   However, I generally perform the snapshot on an Operating System vastly closer to that to which it would be deployed.   Something such as perhaps the oldest version of Win 10 in my deployed base.  Windows 1903 was EOL last year, so I would hope no devices are older than that and could perhaps be a good base unless my environment was standardized to a more current version.


    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below!

  • Could I ask a question.

    if you has success capture chrome ...Could you kindly provide your procedure to let me compare which step that I have in-correct.



  • Let me re-explain my test environment I refer to TID7017277 to build a clean OS to install MFDC Then execute a snapshot to encapsulate Chrome. Then generate an exe But this package is currently executed in the following environment

    1. Win10 (2004) is missing chorme_elf.dll file

    2. I will use Vmware Snapshot to return to a clean environment where MFDC has not been installed on the clean OS that has just installed MFDC, and run this Chrome.. An execution error message appears

  • I did an experiment
    I use Win10 2004 version to set the operating system according to the TID7017277 technical document
    Then make a VMware snapshot.
    1. I use this environment to install MFDC 20.8 (20.9 is still using MFDC 20.8 version), then I packaged Chrome 87 version appeared, and then the test execution error D0000428

    2. I revert snapshot, install Turbo 12.7 version and use turbo responsity, he does not have 87 version, I can only download the closest version Chrome88.... The generated Chrome.exe shows the same error message

    003(Using Template).png

    Regarding the snapshot method of MFDC, do we have a standard snapshot method to encapsulate these common APPs (IE/Chrome/Firefox/Java...)

  • I am having the same problem trying to package Chrome. I have tried multiple installation sources (EXE and MSI), capture methods, capture options, and MFDC versions. There is something extra hateful about Chrome that is interfering with MFDC. It would be great if Micro Focus could put out a YouTube video on how to package a douchey application with Chrome as the test subject. 

  • Verified Answer

    Do you know how to Import the Pre-Existing Chrome Virtual Applications from the Turbo Store?

    In general, there should not be any reason to even do capture for items in the store.


    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below!

  • I have a working chrome app that I pulled down from the Turbo Store. As I recall, it was not current when I downloaded it and I do not think I still have access to the Turbo Store. It is great to have a shrink-wrapped option, but what happens when I have a upgrade what I have in a hurry? 

Reply Children
  • Access to the Store is Free.  Anyone can make a Free Account.  The license is what allows your Virtual App to function beyond a brief trial.

    If you are in a Hurry, then you 100% want to use the store.  They are almost all up to date.

    If you want to modify the base install from the store you have a couple of options...

    #1 -YOu can build your own layer that has all your desired settings that include file and registry tweaks.  Then you just re-apply that layer on top of the new builds as they come down, usually shortly after the new versions are released.

    #2 - You can just quickly make the changes in Chrome itself and merge the sandbox changes back.


    By no means would I ever recommend just doing a "Quick Snapshot" and then going.  I would want to understand each and every file in the virtual app.  Each and every Registry Key.  Understand where and how every process interacted with the physical file and registry system so I could properly assign the properly isolate or not isolate as appropriate, etc...

    And of course, those could change from version to version if a vendor makes under the hood changes. 

    Luckily most apps will just work, but some can be quite complex.

    Thankfully, Turbo Engineers with significant professional experience with the inner workings of Software and the Windows OS spend a great deal of time fine-tuning all of that for free for many applications.


    If one was curious, one could snap their own Chrome Install and then compare versus a professional build line by line for all files, folders, and registry keys including their isolation levels to see the things changed, but it may only be valid for a point in time.


    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below!

  • To be fair, it was a couple of years ago when I last downloaded a template from Turbo. It worked well and I was able to customize it with the lockdowns I needed. The logon in MFDC to the reporitory stopped working for me and I assumed that I had lost access because the same credentials worked on 

    The sales dept. at Turbo confirmed that I have a valid entitlement for downloading preconfigured apps. I am now getting a .NET error (shared in email) before being prompted for credentials for Once I can get past the errors, I will just use the preconfigured Chrome app instead of trying to build Chrome on my own.