ZENworks Patch Management Agent Utility

New Version:

Utility to install/remove/update ZENworks Patch Management Agent

This utility has been written by Lumension (Patchlink) but is not supported by them, or by Novell.

You can use this utility to install the ZPM Agent version to a PC, or remove the agent, or upgrade to this version.

This utility will remove an agent on the machine if there is one, then install the version you are sending to it without requiring a reboot or any user intervention.

  • Unzip zpmagentutility642420.zip to any directory, remember where you put it!

  • Go to Start, Run, type CMD

  • Navigate to the location of the zpmagentUtility folder you just created. For example type:

  • Cd c:\zpmagentUtility

  • You should now see at the command prompt: c:\zpmagentUtility>

  • From the command prompt enter the command line for the install as documented in the next sections:

  • In the command line, make sure the name of the zpmagentutilityXXXXXX.exe is the same as the name of the file of the version you are using, i.e.,

    zpmagentutility642420-x86.exe for Windows 2000/XP/2003

    zpmagentutility642420-x64.exe for Windows XP/2003 (x64)

    zpmagentutility642420-vista-x86.exe for Windows 7/Vista/2008

    zpmagentutility642420-vista-x64.exe forWindows 7/Vista/2008 (x64)

NOTE: With the new agent you can pass the parameters in order, just put the switch and then the value after it.

To install agents using PSEXEC (obtainable from http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx )

**Important, make sure PSexec and zpmagentutilityXXXXXX are in the same folder, the -c option copies the file to the destination

For a single computer install:

Psexec \\computername -c zpmagentutilityXXXXXX.exe /install /server=http://plus-servername /serial=88888888-88888888

For multiple computer install:

To install from a list of computer names create a text document with only computer names, no backslashes.Locate the file inside the same directory
Psexec @filename -c zpmagentutilityXXXXXX.exe /install /server=http://plus-servername /serial=88888888-88888888

To install with a proxy

Add "proxyname:8888" to the end of the line like follows
/install /server=http[s]://servername /serial=88888888-88888888 /proxy=proxyname:8888

To Install with Auth Proxy

Add "proxyname:8888 proxyuser proxypass" to the end of the command:
/install /server=http[s]://servername /serial=88888888-88888888 /proxy=proxyname:8888 /proxyuser=proxyuser /proxypass= proxypass

Below are extra commands for using the zpmagentutilityXXXXXX.exe


/remove		Removes all old agent data (if any)
/unregister Removes all old agent data and unregisters the agent from PLUS (probably slower than /remove)
/install Removes all old agent data (if any) and installs the PatchLink Update Agent
** The following require the /install option
/server=http[s]://servername *Required
/serial=88888888-88888888 *Required
/proxyuser=proxyuser **Require Proxy Option and Proxy Pass Option /proxypass=proxypass **Require Proxy Option and Proxy User Option
/path="X:\Path" ***6.4 Agent Only
/upgrade Removes all old agent data and upgrades to the PatchLink Update Agent (can also be a "downgrade")

In some cases, you may need to provide the local administrator credentials to the target computer via the command string. In order to supply this information, you would add the following items before the -c flag

-uUserName -pPassword

For example: Psexec @filename -uAdministrator -pPassword01 -c zpmagentutilityXXXXXX.exe /install /server=http://plus-servername /serial=88888888-88888888

Return error code Values:
Return Values:
Var. Agent installer returned MSI return code
0 Agent installed successfully
-50 Agent removal complete
-1 No parameters passed
-2 No parameters passed to /install
-3 First parameter passed is invalid
-4 Too many or not enough parameters (Less Than 3 Or Greater Than 8)
-5 First parameter passed is not /install when passing multiple parameters
-6 Invalid URL
-7 Invalid Serial
-8 Invalid Path
-9 Windows Directory entered as Install Directory
-10 System Directory entered as Install Directory
-11 Invalid Proxy (Do Not Use http://)
-12 Invalid Proxy
-13 Invalid Proxy User Name
-14 Invalid Proxy Password
-15 Invalid Group List
-16 Path option used with Agent Utility less than 6.4
-17 Authenticated Proxy option used with Agent Utility less than 6.3
-18 Group option used with Agent Utility less than 6.3
-19 Server entered more than once
-20 Serial entered more than once
-21 Path entered more than once
-22 Proxy entered more than once
-23 Proxy User entered more than once
-24 Proxy Password entered more than once
-25 Groups entered more than once
-26 Proxy User/Password entered without accompanying Proxy User/Password
-27 Authenticated Proxy used without specifying Proxy
-28 Invalid Architecture
-29 AgentID is missing, unable to upgrade
-30 Cannot copy MsiZap.exe to %TEMP%
-31 Cannot copy sc.exe to %TEMP%
-32 Cannot kill gravitixservice
-33 Cannot kill gravitix9xservice
-34 Cannot kill pddm
-35 Cannot kill dagent
-36 Cannot kill PLServiceMonitor
-37 Not all required parameters passed
-38 Error parsing install command parameters
-6000 Non-Vista Agent Utility executed on Windows Vista
-Var. Drive Space Check failure (Disk Availability * -100)
10000 Agent unregistered successfully
10000 Agent not unregistered successfully
3010 Agent will run but needs a reboot

PSEXEC error codes that you may receive can be located with a description from the following website:


How To-Best Practice
Comment List
  • in reply to MigrationDeletedUser
    see the reply I just made to the last guy - the archive is OK, I promise...
  • in reply to MigrationDeletedUser
    not sure what you used to download the file, but I iknow that Cool Solutions have had some issues when folks use IE to download - I just downloaded it now (on vacation, in the middle of rural France :)) using flashget and the MD5 sum is what I said, and the file does extract correctly. For your other question, best place to ask is in the support forums, in the patch-management forum, where I'll be pleased to help
  • The archive appears to be invalid. I can't even uncompress. Can someone please re-upload this utility? Thanks in advance.
  • I am also getting a single file with no extension when I unzip the download. The MD5 is not what you list here. I have tried downloading the file several times with the same result (insane, I know!)

    Also, can you tell me why I can't get the updated agent from my Patchlink server? Under Devices|Install it is still showing the agent version as, the server is at I do show a vulnerability to patch the agent to, but also need the install for new machines.

  • Check the MD5 sum - should be 377c94cdca090fb8d39282417b46ddc3 zpmagentutility642420.zip
    To use with ZENworks, just use an app object/bundle and run as unsecure system user
  • When I extract the files from the zip I get a single file named zpmagentutility642420 without an extension. Is there something I'm missing?

    Also, any hints on how to use this with ZENworks instead of (or with) PsExec?