Migrated DB to new server, now ZCC won't load if old server down

ZCM 20.2


Linux primaries

I migrated our ZCM database from one MS SQL server to another, a few weeks back.  Today I noticed that the old server was still up, so I shut it down.  I then noticed that I could not log into ZCC anymore.  I started the old DB server up and can log in again fine.

When I try restarting ZCM services with the old SQL server down, the ZCC login page will not load at all.

I verified that I have changed the server value in both the zdm.xml and zenaudit.xml files.  The data from the clients is being recorded in the DB on the new server and any changes to bundles is in the DB on the new server.

I haven't been able to find anything indicating other locations to change the DB server, other than the antimalware, which does not have any values in it as we don't use it.

I've tried adding a hosts entry on the primary server that points the old DB server name to the address of the new DB server, but again no luck.

Any suggestions?


Parents Reply Children
  • Hi Aaron,

    I had tried both.  I think I've found where the issue is though.  It seems that OSP is not updated with this process, or at least didn't update in my case.  I found that the osp.xml file has the old DB information in it. 

    So I'm on to get that updated.  I'm working on a cloned system of our production, so I don't have to get downtime for this.  Luckily I used the cloned system to test the DB migration and still have both the new and old SQL boxes in this environment too.

    Right now I'm stuck with the microfocus-zenworks-configure -c GenerateOSPProperties failing on the PKCS12 integrity check.  It seems to update the osp.xml file, but the zcc page states The "OSP Configuration" service (identifier: "auth") is not running.

    On the bright side, there is no traffic to the old DB server anymore.