Help upgrading from 2020 U1 to 23.4 & ZCC not loading

We have a ZCM 2020 U1 server (running on SLES, not Appliance) we are a bit behind and are attempting to upgrade. We think the correct path to upgrade is:
2020 U1 -> 2020 U2 (via .iso/media)
2020 U2 -> 23.4 via system updates
23.4 (SLES) -> 23.4 Appliance via backup/restore  (unsure about this, we haven't located a 23.4 appliance download)

We have 23.4 & 23.3 listed in system updates today, they have been downloaded to the server.

We conduct the upgrade to 2020 U2 without issue and can login, server seems healthy, but going further has not been working in our off-line lab tests.

We first tested 2020 U2 -> 23.4, System Update Status stopped at 99% and never completed - waited overnight, reset test VM and tried again. The last entry in system-update.log was "Triggered ZeUS Refresh. Exit Code: 0"
A manual zac ref from the server console works & opening the Zenworks Agent on the Server GUI shows it running 23.4 with a recent server contact time.

https://SERVER_HOST_OR_IP:7443 never works, there's not response/page times out.
netstat -nl | grep 7443 returns nothing listening
docker ps shows zenadmin-mgmt running
systemct status microfocus-zenadmin-mgmt  shows service running.
We can't manage to login to the new ZCC Management site, it's like it's not listening at all. Temporarily stopping the firewall and server reboots do not help.

For troubleshooting, we tried 2020 U2 -> 23.3 and had similar results, last system-update.log does a ZeUS Refresh, then nothing more & nothing listing/responding on 7443. The only behavior difference is
the System Update Status never showed progress (the page loads, but never showed an update was in process - maybe we refreshed it too late and it was done?).

Are we doing the steps incorrectly or in the wrong order?
Any idea what we should look at to figure out why the ZCC management isn't working even though docker & systemctl show it should be running?

Thank you,

Joel

  • To add:
    on 23.3, I found the log /var/opt/microfocus/zenwroks/admin-mgmt/catalina.out and found it had an error: Failed to initialize component [Connector [HTTP/1.1-7443]]... /etc/opt/microfocus/zenworks/security/server.keystore (Permission Denied)

    When I looked at the permissions of that file, it is owned by zenworks:zmanusers with u+rw,g+r and no other permissions. As a test I chmod o+r server.keystore and restarted
    microfocus-zenadmin-mgmt  & now it starts
     I got a similar error regarding /etc/opt/microfocus/zenworks/security/ldap-ssl-certs (Permission denied)


    But I have another problem.  When I go to https://HOSTNAME:7443/ the login page redirects me to HOSTNAME/.../auth (no port 7443) and this fails..
    Is /osp supposed to be part of the 7443 server or do I have a problem with the 443 https service now too ??

  • It's been a few weeks since I posted this, so I'll try again because I'm going a bit crazy trying to figure this out.

    We have a SLES ZCM server running 2020U1 that we want to upgrade to the latest Zenworks and likely do a migration to appliance. What is the correct path to do this?

    The latest appliance version I saw was 2020U2, so is it safe to assume we should first upgrade our ZCM server from 2020U2 and then deploy the appliance & migrate at 2020U2  (do a backup/restore with both on 2020U2)? After migration to appliance at 2020U2 do a 23.4 upgrade?

    The move from SLES to Appliance is proving to be very difficult and I am finding the documentation to be quite frustrating and possibly downright incorrect at times..

    For example, docs for moving to appliance say to take a database backup and link to another document where zman backups are an option. OK, easy enough I take a zman database backup. Later when following the same appliance documentation, I'm instructed to follow a different guide to restore the database. I start following that guide and it has me drop users and then I get stuck because I have a zman database, not a .sql backup. I find instructions of how to restore a zman backup somewhere else and it fails because I dropped the users.

    I have an open case, so I bring this problem to the tech assigned and I'm told to follow a completely different set of backup/restore instructions (that I've never stumbled across) that seem to have steps that don't apply to us at all (we are a single/stand-alone primary server).

    I've found other docs that are outright incomplete - like they fail to remind you to su to the zenpostgres user Or they simply are missing steps. One had a step that basically said "Execute this command:"...and that was it. No command.

    Maybe I'm being overly thick, but why is this so difficult? Our Zenworks 7 -> "Modern" ZCM migration hooked in a tool that transferred all the data/settings/bundles. Is there not such a tool to move a server from SLES to appliance? (I know that tool wasn't perfect - I recall modifying a lot of the bundles after the fact, but it certainly was much better than what I'm looking at now).

    Help.....

    -Joel

  • What is your Support Ticket....

    I can take a look.

    I do apologize, the steps and docs are not easy.

    They are building some tools to help do migrations....but they will only apply once you are at 23.4

    Getting to 23.4 may be hard to based on your current version of SLES.

    Once you get all on Appliance, things are vastly easier.  Over simplified....but you have an OS Disk and a Data disk and just need to snap on a new OS disk.

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • Hi Craig!

    Case number 02792500

    It seems like we've hit every possible problem on our way up. trouble with zen-backup-restore.sh has been fun.

    Yeah, I'm thinking our best use of time is to move off our SLES server, it's been around for a while. If I have to do a backup/restore, I'd rather move to appliance vs. setting up on a new SLES install.

    Take a look and see if you have any hints for me!

    Thanks,

    Joel

  • Thanks Joel....

    I'm fairly sure we were discussing your case today in a Team Meeting.

    The Front-Line engineer has another back-line engineer involved so they may both get with you directly.  Make sure both are on a planning meeting to save some back and forth.  The FL engineer is good, but the BL guy is super duper.

    --

    Part of the issue is the old Docs were not the best and often missing steps.  The Doc team fixed stuff in later docs, but due to changes in ZCM it's not as simple as doing the updated steps in current docs for older versions.

    --

    I don;t want to say too much because the other Backline Engineer is Excellent.

    The primary pain point is for Customers still on SLES and Pre-ZCM 20.2 because none of the supported versions there are supported on 23.4......so you can't just upgrade to 23.4 where the docs are better and then swap stuff.

    --

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • Thank you Craig,

    I plugged away at this a bit more yesterday and managed to find the right set of documentation and commands to keep me going forward.  I managed to make it to 23.4 on appliance!  I've been doing this in a lab/test area, so now I'm reverting and doing it again to make sure my notes are good before doing our production servers.

    It certainly feels like I've hit every branch of the tree on the way down as I've tried to get this working...

    -Joel

  • Great!  Glad to hear it!

    Sorry, it was such a pain....

    This is an area where development is working on process improvement both in the methods used and improved docs.

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks