Errors after upgrade to 2020.2

I have the same problem, that was resolved in community.microfocus.com/.../1922730: No details is shown about the devices in status "Update Assigned".

zcc.log:

Caused by: org.postgresql.util.PSQLException: ERROR: operator does not exist: character varying = bytea
Hint: No operator matches the given name and argument types. You might need to add explicit type casts.
Position: 101


I have open a case for that, but no resolution have been proposed till now.

Can I get the queries, that resolved the problem? See "Craig will be sharing a couple of queries with you.. Hope that helps.." in community.microfocus.com/.../1922730.

 3681.zcc.log

  • What is the Case #?

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • This is the Case Number 02850976. We had a remote session with the Case owner today. He identified, that the issue is known and the ZCM_20.2.0_FTF_Server_998 should resolve it.
    I hope it's true and I am preparing to install FTF.

  • Any Reason why you are looking at 20.2 FTFs instead of something such as 23.4?

    Note: If sticking at 20.2 after applying 998, you should apply the latest post 998 patch as well.  998 is required for before you can apply any later patch.  I would not consider 20.2 stable until well past patch 998.

    Most folks found the FTF process harder than moving to the latest version.

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • Looks like your Primary Server OS does not yet support later versions...So Official 1016 FTF for ZENworks 2020 Update 2 would be highly recommended post 998 until you can get your OS upgraded to support 23.4

    But make sure it is a version that is supported on both 20.2 as well as 23.4.....

    Moving to an Appliance is an option too.

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • Yes, I know about the compatibility requirements of SLES version with ZCM version.

    However, it is not clear to me from the manual whether the 17.4 device agent is supported in ZCM 23.4.

  • Yes.  They will work fine.

    There is one caveat.....

    "zman security" is a new setting to control new security features in zenworks.

    It is OFF by default on servers Upgraded to 20.2 or later.

    It is ON by default for newly installed servers.

    Make sure it is OFF on your primaries until all your agents are upgraded to 20.2

    --

    Note: You will also see quite a few issues with the older agents until you get your 20.2 server patched to FTF 1016.  

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • I updated ZCM with ZCM_20.2.0_FTF_Server_998:

    zen:~ # docker image ls
    REPOSITORY          TAG                 IMAGE ID            CREATED             SIZE
    antimalware         20.2.0.998          385d1a9c62ae        18 minutes ago      1.01GB
    antimalware         latest              385d1a9c62ae        18 minutes ago      1.01GB
    zenserver           20.2.0.996          0f554462e63f        19 minutes ago      1.22GB
    zenserver           latest              0f554462e63f        19 minutes ago      1.22GB
    zenloader           20.2.0.995          2af617bc16fa        19 minutes ago      760MB
    zenloader           latest              2af617bc16fa        19 minutes ago      760MB
    zenjoinproxy        20.2.0.997          6655cdb78d19        19 minutes ago      672MB
    zenjoinproxy        latest              6655cdb78d19        19 minutes ago      672MB
    zencore             20.2.0.998          1d1694645bb4        19 minutes ago      764MB
    zencore             latest              1d1694645bb4        19 minutes ago      764MB

    No changes:


    ZENworks 2020 Update 2, updating devices in pending status ->

    ZENworks Control Center - 172.19.11.70 has encountered an error. The details of the error are shown below.

    Where would you like to go next?

        Home
        Deployment
        Devices
        Users
        Policies
        Bundles
        Security
        Subscribe and Share
        Modern Management
        Reports
        Audit and Messages
        Diagnostics
        Configuration


    Error Details:

    See the ZENworks Control Center log file (zcc.log) for the full stack trace.

    zcc.log:

    ...
    Caused by: org.postgresql.util.PSQLException: ERROR: operator does not exist: character varying = bytea  Hint: No operator matches the given name and argument types. You might need to add explicit type casts.  Position: 101
    ...

  • I'm not surprised that did not fix it.....But I strongly recommend Patch 1016. for the server now that 998 has been applied.

    Despite it's innocuous name......

    In many ways ZCM 20.1 -> 20.2 is a far bigger upgrade than the entire (ZCM 11.4->17.0->17.1->17.2->17.3->17.4->20.0->20.1)

    --

    That is very unlikely to resolve your issue which is more likely a "Data" issue in your DB and less a Code issue.

    I recall the other time I saw this....We had to run a query to clean up some orphaned entries.  The queries were very specific and referenced a specific device guide, so it was not a generic query.

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks

  • I returned to the status before installed ZCM 2020.2 for a while (snapshot, disabled network card). The same pending devices with error during viewing details after update are OK before updating.

    Is it necessary to apply Patch 1016, when there is no Windows Primary server in the zone?

    "Official 1016 FTF for ZENworks 2020 Update 2"
    Points to Note:

    1. It is recommended to apply this FTF if the current applied FTF version in your zone is from 20.2.0.999 to 20.2.0.1004 (both inclusive) and having at least one Windows Primary server.

    ...

  • Verified Answer

    The Error you were posting about was a data error ....Not a failed Update.  No need to reverting and re-applying would not help.

    I don't recall all of the details around the data error....I worked with engineering to get a few queries to identify some bad SU entries around specific devices.

    After you upgrade to ZCM 20.2

    Both 998 and 1016 are 100% required for stability and proper operations even if you have no Windows Servers.

    It could be bad wording and Update 1015->1016 just fixed a Windows Issue.  But there would be no point in applying 1015 when 1016 is out. 

    The Server Updates in 20.2 apply entire new dockers and the number of fixes between 998 and 1016 is innumerable.  998 should not be considered stable.

    Again...This is not likely to fix your error AFAIK.  That will likely be fixed by some SQL queries that are 100% unique to you.

    --

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

    Be sure to "Like" My (and a few others) Cool Solutions below! 

    https://community.microfocus.com/members/craigdwilson/bookmarks