OPSWtwist Error in 9.1>10 Upgrade

In testing out an upgrade from HPSA 9.1 to 10 in my lab (single box core with HP-supplied Oracle install on the same box), I get an error that stops the upgrade cold in the processing of package OPSWtwist-50.0.37360.0-0.i386.rpm.  I backed out my CORDS and hotfix rollup before attemting the upgrade, and now I have an unusable core, the app will not start now, it was working before I started.  "opsware-sas list" does not even show twist anymore, and an uninstall says the core is still at 9.1.

 

Here is the error out of the log:

 

Verifying dependencies
Verify hostname "localhost" is listening on port 1007: SUCCESS
Verify communication with local Spin service: SUCCESS
[Jul-16-2013 16:02:03]  Processing package OPSWtwist-50.0.37360.0-0.i386.rpm.
useradd: user twist exists
Failed to add user twist
error: %pre(OPSWtwist-50.0.37360.0-0.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping OPSWtwist-50.0.37360.0-0
[Jul-16-2013 16:02:03] Installation of package /var/tmp/hpsa_media/packages/./Linux/OPSWtwist-50.0.37360.0-0.i386.rpm failed
[Jul-16-2013 16:02:03] Exiting Opsware Installer.

 

Has this ever been seen before?  Our Lab is a simple 1 box system but it has the same CORD and patch level as Production, so I'm kind of concerned about a show-stopper so early in the process.  Since this is a Lab box it is unsupported so I cannot put in a ticket,  but this does not bode well for a Prod implementation.  Has this ever been seen before?  Thanks!

 

Bob

  • Hi Bob,

     

    Please be aware that upgrades from SA 9 to SA 10 needs to be done by our professionals service department or by a certified partner, but seems like you are testing on your own on a dev environment.

     

    That said, have you followed every single step mentioned in the SA 10 upgrade guide for the the SA config that you have?

     

    On the core you should run /opt/opsware/oi_util/bin/run_all_probes.sh run > probes.out

     

    To see the current status of the core.

     

    Please let me know.

     

     

     

     

  • Eduardo,

     

        Yes, this is my Lab core.  But I have specifically been told by HP at Discover, and it is in the HPSA 10 documentation, that HPSA 10 is customer-upgradable, as long as your core is one of the approved configurations.  And I followed all of the directions, even correcting the bad mount point (-primary instead of primary, I found that myself).

     

        Anyways, looking at the probe output I seem to have an incomplete upgrade - the upgrade attempt was not completely backed out automatically after the failure and if I try to run the uninstall from the HPSA 10 media it tells me the core is 45.0, which is 9.1.  I'm attaching the out file.

     

        I'm not as concerned about getting back to 9.1 as I am wondering why the HPSA 10 upgrade did not work, and if it is an issue that has been seen before and that I can work around.  I'm concerned about this happening when Production is upgraded.

     

    Bob

  • My apologies, SA 10 is also customer upgradeable....sorry about that.  Customers can upgrade from SA 9 to SA 10.

  • Bob,

     

    Try restarting SA processes, if possible try rebooting the server.  Then try upgrade again and let me know the failure if you get any.  

     

    If issues are still seen, please place the output here and get me a scenesnap to further check:

     

    support.openview.hp.com/selfsolve/document/KM1464600

     

    I would also appreciate Install logs.

     

    Get me a coretographer:

     

    http://support.openview.hp.com/selfsolve/document/KM760430

     

    Did you install any rollup patches on this system...but well anyway, the Scenesnap should tell me...

     

    Regards,

     

     

  • Hey Bob,

     

    Can you please run the following bash script and put here the entire output:

    #!/bin/bash -x


    # Check if user exits
    if [ `grep "^twist:" /etc/passwd | wc -l` -eq 1 ]; then
    echo "User twist exists"
    else
    echo "User twist does not exist"
    fi

     

    if [ "$?" -ne 0 ]
    then
    echo "Failed to add user twist"
    exit 1
    fi

     

     

    In your case is really odd since you're having a return code !=0 for an echo command, so let's see the output.

     

     

  • Mihai,

     

       Here is the output:

     

    [root@usrpkhpsald1l tmp]# ./test.sh
    grep '^twist:' /etc/passwd
    wc -l
    '[' 0 -eq 1 ']'
    echo 'User twist does not exist'
    User twist does not exist
    '[' 0 -ne 0 ']'
    [root@usrpkhpsald1l tmp]#

     

    Bob

  • ok, so the twist user is missing

     

    wondering why existed at the 1st attempt.

     

    Can you please run again the upgrade script and keep us posted with the result?

  • Eduardo,

     

        Thank you for your time.  I appreciate you looking at this.

     

        I had hotfix rollup 34491 installed, and I uninstalled the hotfix rollup and CORD patch per the instructions.

     

       I rebooted the server and retried the upgrade.  Still the same error.  As I put in the update before, there is no twist user anymore and no twist component also (opsware-sas list does not show twist) - this was a functioning core before I first attempted the upgrade on Friday.

     

        I am attaching all of the files you requested, except the scenesnap, the file is 43MB and the max to attach here is 20MB.  Let me know if you want me to get it to you some other way, maybe I can split it up.  Thanks again!

     

    Bob

  • Mihai,

     

        I have tried the upgrade several times, and it always fails at the same point: 

     

    ............WARNING: an error was detected while running an external
    command or script. The output follows:
    useradd: user twist exists
    Failed to add user twist

     

    I have uploaded a full slice upgrade log in a previous response if you want to look at that.

     

    Bob

     

  • Hey Bob,

     

    But, did you run the installer or the upgrade script?

    /<mountpoint>/primary/disk001/opsware_installer/hpsa_upgrade.sh (SA_10_UpgradeGuide.pdf page 15)

     

    If you ran the installer then you "fixed" the core :)