MpC error for SA only

This started a couple of weeks ago. Seems to work when I set the product to nas, but sas fails:

[root@hpsapricore marketplace-connector]# ./ write-config --setting=product=nas
[root@hpsapricore marketplace-connector]# ./ list-streams
Product Service Stream
nas security security.vc_cisco_diag
nas security security.vc_cisco
nas security security.vc_juniper
nas security security.vc_juniper_diag
nas security security.vc_aruba
nas security security.vc_aruba_diag
nas security security.vc_f5
nas security security.vc_huawei_diag
nas security security.vc_huawei
nas security security.vc_hpn
nas security security.vc_checkpoint
nas security security.cc_pci_hpn
nas security security.cc_pci_cisco
nas content content.na_drivers

[root@hpsapricore marketplace-connector]# ./ write-config --setting=product=sas
[root@hpsapricore marketplace-connector]# ./ list-streams
Download failed due to error in downloading content for specified stream.
Error while fetching streams list. Please check log file for error information.
[root@hpsapricore marketplace-connector]#

  • As our colleagues from the Marketplace platform are still working on the remaining issues you may want to carry out the import with a manual workaround.

    1. Using a web browser download the marketplace content needed. You would only need the binaries that have changed since your last successful import eg. In the case of CIS compliance for RHEL the files would be: (17.9 KB) (17.0 KB)

    2. Move these files to the correct location on your SA core. For CIS compliance this would be /opt/opsware/marketplace-connector/cache/security/sas/ec_cis_rhel/ . You can identifiy the correct cache location based on the previous downloads.

    Ensure there are no older releases of the same content archives in the same cache directory

    3.Run the marketplace connector with the import only option

    # /opt/opsware/marketplace-connector/ import

    Note that on new MpC setups there might be other prerequisites needed to be downloaded for some content packs, but this should not be the case if you've already done successful imports for previous versions of the same content packs.

    The Marketplace platform team is treating the issue with the highest priority so I hope you will not need these steps if you're able to wait a few days to do the content refresh.

  • Just coming back to this - my SA content is partially working. Had to drop many streams to get a successful completion.

    Now my NA MpC is throwing the checksum errors (where is previously worked):

    ./ download

    Determining content status information for stream vc_cisco_diag
    Finished determining content status information for stream vc_cisco_diag

    Downloading content
    Download complete. Content saved under /apps/marketplace-connector/cache/security/nas/vc_cisco_diag
    Checksum validation is failed... MpC will exit now.

  • Hello, RnD is aware of this latest development. The Marketplace team had fixed the hash generation for all files yesterday and also added a new hashing algorithm, however this has now triggered a problem in MpC that doesn't yet support the new algorithm.

    It's still being analyzed but the likely solution will be to deactivate the new hashing alg on Marketplace for the time being.

  • Makes sense now. How exactly can we disable hashing on the client side? We use pluggable checks from the content for server auditing and really could use a workaround now. Thanks!

  • You an attempt the import again. This should be solved now.

  • Seems to be working now. Thanks for the update on this discussion.

Reply Children
No Data