Idea ID: 2772098

Support SQL Server on compatibility level

Status : Waiting for Votes
Waiting for Votes
See status update history
over 1 year ago

SM supports RDBMS systems based on versions.  During the long lifetime of a product release new versions of the RDBMS may become available that are then not QA'ed and therefore not supported.

SQL Server addresses this scenario by compatibility level - allowing to use current versions while acting like older.

https://docs.microsoft.com/en-us/sql/t-sql/statements/alter-database-transact-sql-compatibility-level?view=sql-server-ver15

So when in compatibility matrix SM would support a compatibility level instead of a exact SQL Server release, customer can choose better the best RDBMS version.

Labels:

SMA-SM