Idea ID: 1674160

URL redirection for SMAX

Status : Delivered
over 2 years ago

Hello,

In the OOB configuration when you type the SMAX hostname only like https://<SMAX FQDN>, you are redirected to https://<SMAX FQDN>/myhome page. However it should be configurable to redirect requests to https://<EXTERNAL_ACCESS_HOST>/saw/ess?TENANTID=xxxxxxxxx&AUTH=SAML page instead for letting end users to log into the system easier. According to Support, it is currently hard coded but should be configurable either at web application server level or through SMAX configuration screens.

Alper Ozdemir

Tags:

  • This idea has been implemented in product release SMAX 2020.02. Check out the release notes for details. Thanks to all of our contributors for helping us continue to improve our products!

  • Great news, this idea has been accepted on our product roadmap. Subscribe to receive updates. (This is not a formal commitment, and subject to change)

  • Thanks for all the votes and comments. We are looking into this as a future product enhancement. Check the notifications box to be emailed if the status changes.

  • Hello,

    A possible workaround is to use load balancer between browsers and  SMAX and/or SMA-SM portal.

    - Setting Load Balancer IP as SMAX Portal IP on DNS but keeping original IP adresses across SMAX/SMA/SM servers by setting etc/hosts file if needed

    -A URL rewrite rule on Load Balancer

    can be used as workaround. We tried on 2 different SMA-SM version 2019.08 and it works.

  • workaround for those interested is to manipulate the nginx ingress controller defintions (sometimes the nginx controller in core namespace, and sometimes in smax namespace); basically manipulating the nginx.conf used by those pods allows for *most* (but not all) of these use cases to be achieved.  Please be aware that this approach may NOT be officially supported by Micro Focus (so please use this information at your own risk and/or confirm directly with MF support);

     

    +1 / following for official support of this