phase transition fail to execute

Hello team.

I have encounter a challenge on smax automatic phase transition are not working once request has been approved or denied.

rule were working fine before but now their not working

below are business rule implemented  before.

  • Approved rule

${entity.TaskPlanForUserDepartmentApproval_GL47NZ4BV.ExecutionPlanCompletionCode == 'Success'}

${(entity.CurrentTaskPlanStatus == null || entity.CurrentTaskPlanStatus == 'Success')}
  • denied rule
${entity.TaskPlanForUserDepartmentApproval_GL47NZ4BV.ExecutionPlanCompletionCode == 'Failed'}
${(entity.CurrentTaskPlanStatus == null || entity.CurrentTaskPlanStatus == 'Failed')}
Please advise what cause the rule to stop working.
  • Please use the workflow debugger to see what's going on. If you cannot figure out where the issue is, please open a support case.

    By the way, in your example above, it appears you have two conditions. If you added both in your if condition, you obviously have incorrect syntax.

    Best regards,

    Brindusa

  • Hi Brindusa.

    The two condition shared are the one tried to implement with different test but not working in prod while working in dev.

    Let me try to use debugger and share update.

    Br,

  • Hi Peter,

    In a condition field, everything has to be in a single ${ } expression, not two separate ones
    So did you mean:

    ${entity.TaskPlanForUserDepartmentApproval_GL47NZ4BV.ExecutionPlanCompletionCode == 'Success' &&  (entity.CurrentTaskPlanStatus == null || entity.CurrentTaskPlanStatus == 'Success')}

    Let us know if you solved your issue by now.

    Regards,

    Ben

    Ben Rabau 

    EMEA Professional Services