Show Configlet - inconsistent return values

I am just dipping my toes into using the API and have a very simple task but have already stubbed my toe and am looking for some help as to what I am doing wrong.

 

The basics of the task are:

* Use interface descriptions to identify which router interfaces connect to our MPLS network

* pull the bandwidth statement from interfaces above

 

I have actually used SOAP and python to mostly solve the issues above but have run into an issue with one device and want that fixed before I go on to actually work with the configs I pull.

 

Below is my issue and I have verified the same behavior using SOAP via Python and the CLI:

For 99% of the devices the following works to get the configs from all of the ethernet interfaces on a router :

NA>show configlet -host Some_good_host -start "interface GigabitEthernet" -end "!"
200 OK: Generic Succeeded
interface GigabitEthernet0/0/0
description MyCompany.backup.uplink, Comcast Business, 50Mbps, Acct xxxxxxxxxx, Tech Support xxx-xxx-xxxx
bandwidth 50000
ip vrf forwarding INET
ip address x.x.x.x 255.255.255.252
no ip proxy-arp
ip access-group SecureOnly in
load-interval 30
media-type rj45
speed 100
no negotiation auto
no cdp enable
service-policy output SHAPE_50M
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/2
description MyCompany.uplink Level3 MPLS Ethernet, 100Mbps , Circuit xxxxxxxxx, L3 NOCxxx-xxx-xxxx
bandwidth 100000
ip vrf forwarding LEVEL3
ip address x.x.x.x 255.255.255.252
no ip unreachables
no ip proxy-arp
load-interval 30
negotiation auto
no cdp enable
service-policy output SHAPE_100M
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
COMMAND COMPLETED

However for one device that is exactly the same as the first one it does not return all the interfaces (notice the "i" is missing from "interface" on the first line of the configlet!) I have physically logged into the device, verified all interfaces are present, are configured to our template and forced a snapshot and checkpoint:

NA>show configlet -host Another_Host -start "interface GigabitEthernet" -end "!"
200 OK: Generic Succeeded
nterface GigabitEthernet0/0/0
description MyCompany.uplink Level3 MPLS Ethernet, 10Mbps, Circuit xxxxxxxx, L3 NOC xxx-xxx-xxxxx
bandwidth 10000
ip vrf forwarding LEVEL3
ip address xx.xx.x.xx 255.255.255.252
no ip unreachables
load-interval 30
speed 100
no negotiation auto
no cdp enable
no snmp trap link-status
service-policy output SHAPE-10M
!
COMMAND COMPLETED

Here is the full interface config on the above (not working) device:

SomeRouter#sh run | begin interface Gigabit
interface GigabitEthernet0/0/0
description MyCompany.uplink Level3 MPLS Ethernet, 10Mbps, Circuit xxxxxxxx, L3 NOCxxx-xxx-xxxx
bandwidth 10000
ip vrf forwarding LEVEL3
ip address 1.1.1.1 255.255.255.252
no ip unreachables
load-interval 30
speed 100
no negotiation auto
no cdp enable
no snmp trap link-status
service-policy output SHAPE-10M
!
interface GigabitEthernet0/0/1
description MyCompany.backup.uplink Cable Modem, Comcast Business, 20Mbps UP, 100Mbps Down, Acct xxxxxxxxx, Tech Support xxx-xxx-xxxx
bandwidth 20000
bandwidth receive 100000
ip vrf forwarding INET
ip address 1.1.1.1 255.255.255.240
no ip proxy-arp
ip access-group SecureOnly in
load-interval 30
shutdown
negotiation auto
no cdp enable
service-policy output SHAPE-20M
!
interface GigabitEthernet0/0/2
description link for SP MPLS Transport
ip vrf forwarding LEVEL3
ip address 1.1.1.1 255.255.255.252
negotiation auto
!