nnmkeytool.ovpl error

I am trying to generate a new keypair and am getting an error -- this is what I run:

/opt/OV/bin/nnmkeytool.ovpl –genkeypair –validity 3650 –keyalg rsa –keystore nnm-key.p12 –storetype PKCS12 –storepass nnmkeypass –alias theservernameiwanttouse.internal

and this is the error I'm getting:

Illegal option: –genkeypair
Key and Certificate Management Tool

Commands:

-certreq Generates a certificate request
-changealias Changes an entry's alias
-delete Deletes an entry
-exportcert Exports certificate
-genkeypair Generates a key pair
-genseckey Generates a secret key
-gencert Generates certificate from a certificate request
-importcert Imports a certificate or a certificate chain
-importpass Imports a password
-importkeystore Imports one or all entries from another keystore
-keypasswd Changes the key password of an entry
-list Lists entries in a keystore
-printcert Prints the content of a certificate
-printcertreq Prints the content of a certificate request
-printcrl Prints the content of a CRL file
-storepasswd Changes the store password of a keystore

The syntax I'm using has worked to good effect as part of generating new certificates that I then get signed, and updating expired signed certificates -- I'm thinking something is going on with Java.