(OO) Support Tip: 'Permission denied' when executing apply-upgrade

0 Likes
The apply-upgrade script is required to execute to upgrade your OO components but it may fail on a Linux node due to the 'Permission denied' error like below:

  # cd <OO_HOME>/upgrade/24.1.1/bin
  # ./apply-upgrade
  ./apply-upgrade: line 3: ../java/linux64/bin/java: Permission denied

The error can be caused by missing the execute permission for the 'java' command called by the script.
To address the error, navigate to <OO_HOME>/upgrade/<current_version>, and then run the command:

  # chmod a+x ../java/linux64/bin/java

In case, run the following command as well.

  # chmod 777 apply-upgrade

See the 'Upgrade in Linux' section of the product manual like below for more details.

Labels:

Support Tip
Comment List
Related
Recommended