OA Installation IPv6/IPv4 Address is not configured


I'm trying to install OA 12.20 on a Windows server but the requirements keep failing for "Check if the IPv6/IPv4 address is configured". I've already checked on my network configurations and the IP seems alright considering I've already installed SiteScope 2023, tried with OA 12.24 and got the same.

Can someone enlight me on how to check the IP Adress config referred on the error?

Some screenshots of the errors and output:


Thank you beforehand.

Parents Reply Children
  • Hello Misaq, 

    I tried the KM but unfortunately it didn't work, after updating the chcp to 437 and re-install I keep getting the same error:

  • Best would be to check with OpenText support for further guidance.

    If you feel comfortable with OS and OA troubleshooting then can try other options like

    Installing the Operations Agent on Platforms with Limitations - Operations Agent (microfocus.com)

    or dig further in the troubleshooting section..

    Installation - Operations Agent (microfocus.com)

    There might be some pre-requisite conflict or OS related issue that may be visible in windows events log.

  • I had to dig further as it was bothering me why the locale is messing with IP address check...

    So following script is responsible for validation...

    <OA install media>/packages/WIN/Windows_X64/ValidateSetup.vbs

    If I am not mistaking it is trying to get IP address validation form ipconfig /all  command and expecting "IPv6 Address" or "IPv4 Address" string  search?

    My guess is that your output for above command is not of that in that format even after change per KB.

  • Hello,

    The issue from OCTCR19G575929 was because of code page issues in cmd.exe which means output like this:

    Windows IP ??

    ?????? ????? ???? ?????:

       ????? DNS ?????? . . . :
       IPv4 ???? . . . . . . . . . . :
       ????? ??? . . . . . . . . :
       ????? ?????? . . . . . :

    ..cannot be parsed by the script.  Changing the codepage to 437 means the output is shown correctly.  This might not be relevent.

    This part of the validatesetup.vbs script uses UCase  which converts everything to upper case to work around any localisation issues:
    If (InStr( UCase(StdOutStream), UCase(IPType & " Address")) <> 0 ) Then
    If (InStr(UCase(Split(StdOutStream,": " )(1)),"(" )) Then
    ip = Split(Split(StdOutStream,": " )(1), "(" ) (0)
    End If

    The error message you get is "IPv6/IPv4 address is not configured, check the oainstall.log at %TEMP% location" which is the output from validatesetup.vbs.  Do you have IPv6 installed?

    What happens if you run:
    netsh interface ipv6 show address

    I think you should get an output like this:
    Interface 1: Loopback Pseudo-Interface 1
    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Preferred infinite infinite ::1

    Which means IPv6 has a configured loopback on Pseudo-Interface 1.

    I'm not sure if a pre-requsite of OA12 is IPv6 at least configured, because ovbbccb uses ::1 to register some endpoints.

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

  • Hello Misaq, duncan,

    Thank you a lot for taking your time to check this question, I checked the ValidateSetup.vbs script and indeed, it seems to validate through the output of "ipconfig /all" if the IPs are registered. I already went through the troubleshooting guide to no avail, sadly.

    Duncan, I ran netsh interface ipv6 show address on the server and this is the output:

    Interfaz 1: Loopback Pseudo-Interface 1

    Tipo direc. Estado DAD Vigencia válida Vigencia pref. Dirección
    ----------- ----------- --------------- -------------- ------------------------
    Otros Preferido infinite infinite ::1

    Interfaz 12: Ethernet

    Tipo direc. Estado DAD Vigencia válida Vigencia pref. Dirección
    ----------- ----------- --------------- -------------- ------------------------
    Otros Preferido infinite infinite fe80::700e:3d1f:8c32:f926%12

    The IPv4 as well as the IPv6 are seen in the ipconfig output

    The only output on %TEMP%oainstall is the next: 

    Thank you again for your help.

  • Hello,

    The script looks for the word "Address" in English.  I'm not sure why this isn't working.  I would recommend contacting Opentext support.

    Sorry I don't have a better answer...

    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button