Monitor not Alerting "On Good"

Hi Experts,

 

I am testing a new monitoring environment, (SiS 11.23) that will send alerts to HPOM, and I am trying to ensure that I get an indication (good alert/event) that things are working correctly when these Windows monitors are first deployed.

 

I have configured 3 alerts with the same Trigger actions: 

 

Alert on status Good  - Once, after condition has occurred exactly 1 times

Alert on status Warning - Once, after condition has occurred exactly 1 times

Alert on status Error - Once, after condition has occurred exactly 1 times

 

(I have configured a separate alert for CPU to trigger an error - Once, after condition has occurred exactly 5 times.)

 

I have switched off "Send Events" in the monitor's  "HP Integration Settings" and switched it on in the alerts.

 

With this configuration, I would expect to get an alert for the appropriate status when these monitors are first deployed. So in this case, with all monitored items working, I would expect a "Good" alert/event to be sent to HPOM.

 

For some reason this is not happening for some monitors, e.g.  two of the 11 services, (Browser and LanManServer)CPU,  and Dynamic Disk.

 

I have checked for the missing services in the HPSiSIntegration Log file and can see the entries have arrived with the expected "good" condition but these do not seem to be getting sent to HPOM.

 

Can you think of any reason for these alerts not arriving at the HPOM Java console while others do?

 

Thanks 

 

 

 

Tags:

Parents
  • Hi Stephen,

     

    For your configuration I would suggest you to use such flow:

     

    1. For the monitors with such alert configuration

    Alert on status Good  - Once, after condition has occurred exactly 1 times

    Alert on status Warning - Once, after condition has occurred exactly 1 times

    Alert on status Error - Once, after condition has occurred exactly 1 times

     

         I would suggest you to prefer the send events option in the HP integration setting of the monitor then alert, to not made extra load on the SIS Alert engine.

     

    1. If you see the event in the HPSiteScopeOperationsManagerIntegration.log but does not see that this evens was arrived to the HPOM, you should better check Construct events from the log lines and send it to the HPOM.
    2. HP Operation Agent log files for the errors (e.g  C:\Documents and Settings\All Users\Application Data\HP\HP BTO Software\log\System.txt). HP Operation Agent is listens for the  HPSiteScopeOperationsManagerIntegration.log and if it was changed – read it, construct events from the log lines and send it to the HPOM.

     

  • Alex,

     

    A little extra background.

     

    Since I wanted to trigger an error event for CPU only after 5 occurrences of threshold breach, I had to use the Alerts option to allow this. And as I was using alerts for CPU, I used the same for all other monitors - This may not have been necessary for all other monitors, but it seemed like it was at the time. 

     

    So, while "Alert on Good" applies to all group monitors as targets, the other Alerts have specific targets as follows:

     

    "Alert on Error" - for all monitors except CPU

    "Alert  on CPUError" - only for CPU monitors

    "Alert on Warning" only for Service monitors

      

    .....

     

    I will try out your suggestion of enabling "Send Events" in the monitor for all monitors except CPU. But I am not sure what you mean by your first point if problems:

     

    "If you see the event in the HPSiteScopeOperationsManagerIntegration.log but does not see that this evens was arrived to the HPOM, you should better check Construct events from the log lines and send it to the HPOM"

     

    Is this a selectable option somewhere?

     

    Please advise.

     

    Regards

    Stephen

     

  • Hi,

    As Alex says problem maybe on OA or OM server. Check system.txt log file for OA in %ovdatadir% for possible errors.
  • Hi,

    As Alex says problem maybe on OA or OM server. Check system.txt log file for OA in %ovdatadir% for possible errors.
  • OK, I have just retested results  using a windows service monitor, with Alerts, and without Alerts. Results as follows:

     

    1. With Alerts in place for both good and warning conditions, and "Send Events" only selected in Alerts, monitor is set like this - Generate Warning if - condition "status" != "running"

     

    a. Changing this to, Warning if condition "status" == "running" 

    -HPSiSOMIntegration log IS updated and   

    -event IS sent to HPOM.

     

    b. Changing this back to original setting, (Warning if - condition "status" != "running")

    -HPSiSOMIntegration log is NOT updated and 

    -event is NOT sent to HPOM.

     

    2. With Alerts removed for this monitor and "Send Events" selected, and with the monitor settings as before - Generate Warning if - condition "status" != "running"

     

    a. Changing this to  - Warning if condition "status" == "running"  

    -HPSiSOMIntegration log IS updated and   

    -event IS sent to HPOM.

     

    b. Changing this setting back to original setting, (Warning if - condition "status" != "running")

    -HPSiSOMIntegration log IS updated and 

    -event IS sent to HPOM.

     

    So, I would expect an OM event to be generate on change of state in either scenario, i.e. switching from "a" to "b" or from "b" to "a", but this only seems to happen in scenario 2.

     

    Please advise.

     

    Apologies for original confusion.

    Regards

     

      

  • OK, I have just retested results  using a windows service monitor, with Alerts, and without Alerts. Results as follows:

     

    1. With Alerts in place for both good and warning conditions, and "Send Events" only selected in Alerts, monitor is set like this - Generate Warning if - condition "status" != "running"

     

    a. Changing this to, Warning if condition "status" == "running" 

    -HPSiSOMIntegration log IS updated and   

    -event IS sent to HPOM.

     

    b. Changing this back to original setting, (Warning if - condition "status" != "running")

    -HPSiSOMIntegration log is NOT updated and 

    -event is NOT sent to HPOM.

     

    2. With Alerts removed for this monitor and "Send Events" selected, and with the monitor settings as before - Generate Warning if - condition "status" != "running"

     

    a. Changing this to  - Warning if condition "status" == "running"  

    -HPSiSOMIntegration log IS updated and   

    -event IS sent to HPOM.

     

    b. Changing this setting back to original setting, (Warning if - condition "status" != "running")

    -HPSiSOMIntegration log IS updated and 

    -event IS sent to HPOM.

     

    So, I would expect an OM event to be generate on change of state in either scenario, i.e. switching from "a" to "b" or from "b" to "a", but this only seems to happen in scenario 2.

     

    Please advise.

     

    Apologies for original confusion.

    Regards

     

      

  • Hi Stephen,

    This is how events work:

    Monitor events (send events in monitor): Event is triggered whenever a status change happens and only at that time.

    Alert events: triggered whenever an alert is fired.

    So for alert events missing check your trigger frequency setting.
  • Hi Stephen,

    This is how events work:

    Monitor events (send events in monitor): Event is triggered whenever a status change happens and only at that time.

    Alert events: triggered whenever an alert is fired.

    So for alert events missing check your trigger frequency setting.
  • Hi Stephen,

    This is how events work:

    Monitor events (send events in monitor): Event is triggered whenever a status change happens and only at that time.

    Alert events: triggered whenever an alert is fired.

    So for alert events missing check your trigger frequency setting.
  • Since these are newly deployed monitors, the status will be "no data to good".

    Will there be an alert on this status change?

  • Hi dasomm,

    No. It will be sent if you check option "manually send first event".
  • Hi dasomm,

    No. It will be sent if you check option "manually send first event".
Reply Children
No Data