Jboss JMX access in BSM 9.26

In BSM 9.25, we can access JBoss JMX directly via, for example, Java Jconsole.

We provided URL like this:
service:jmx:rmi:///jndi/rmi://dps:29601/jmxrmi

And was able to run methods in different mbeans:

 

In BSM 9.26 we can't do it anymore. I understand that JMX/RMI ports changed, I tried all ports mentioned in docs, but without success.

Maybe anybody know how to do it in BSM 9.26? Thanks!

  •  

    Hi,

    Remote access to the JMX console is disabled by default, so it can only be accessed from each server locally.

    You can enable remote access from Infrastructure Settings (this is from the Platform Admininstation PDF, pg 95):

    1. Select Admin > Platform > Setup and Maintenance > Infrastructure Settings.
    2. Select Foundations.
    3. Select Security.
    4. In the Security-Login table, locate Restrict remote access to JMX console. Change the value to
    false.

    The port is 29000.

    Regards,
    Tim

  • Tim, thank you for reply!

    "Restrict remote access to JMX console" is turned off, of course. I can access HTTP JMX console via http://<bsm_srv>:29000.
    But I need to access JMX directly (without HTTP), for example via jconsole.exe...

     

  • Depends on which service, it could be one of these REMOTE_JMX_PORT in the startup scripts under <BSM>/bin folder

    bus_run.sh:REMOTE_JMX_PORT=29623; export REMOTE_JMX_PORT
    odb_run.sh:REMOTE_JMX_PORT=29612; export REMOTE_JMX_PORT
    opr-scripting-host_run.sh:REMOTE_JMX_PORT=29628; export REMOTE_JMX_PORT
    schedulergw_run.sh:REMOTE_JMX_PORT=29616; export REMOTE_JMX_PORT
    scheduler_run.sh:if [ -n "$REMOTE_JMX_PORT" ]; then
    scheduler_run.sh: echo "REMOTE_JMX_PORT was override"
    scheduler_run.sh: REMOTE_JMX_PORT=29616; export REMOTE_JMX_PORT
    wde_run.sh:REMOTE_JMX_PORT=29604; export REMOTE_JMX_PORT

  • Thank you, brahmasky! But it's JBOSS, and it runs another way.

    So I'm anwsering to me by myself :)

    Now we need to start jconsole with "C:\HPBSM\jboss-as\bin\jconsole.bat"

    Tested URL to connect is:

    service:jmx:remoting-jmx://dps:4447

  • Verified Answer

    Hi Konstantin,
    you should mention that this requires the installation a Java JDK on the system you run JConsole on, otherwise jconsole.bat will fail as it requires jconsole.exe, jconsole.jar and other files which are not part of the JRE.

    Another thing is that you cannot connect to a remote BSM system using default JMX user and password.
    You need to add a JBoss user for this, as described (for example) in the manual
    Using System Health
      Chapter 1: Setting Up System Health
        How to add a JBoss user

    Then it works like a charm:

    Installed JDK to c:\program files\Java\jdk1.7.0_79
    cd C:\HPBSM\jboss-as\bin
    set JAVA_HOME=c:\program files\Java\jdk1.7.0_79
    jconsole


    Greetings
    Siggi

  • Siggi, thank you for valuable information!

    I need to add - added user start working imeediately, no need to restart Jboss.

    Regards,
    Konstantin