Downgrade HP OM agent 12.x to 11.14 in VPV or Cloud Optimizer

Hello,

We have a virtual appliance with Cloud Optimizer in a CentOS, and We installed the agent version 12.x.

The problem is that I need to integrate OMi with VMWare and to do this I need to use the version 11.14 of HP Agent.

The last time I tried to uninstall the agent in VPV, the VPV was uninstalled together, could someone help me to uninstall only the agent and not the Cloud Optimizer?

 

Regards,

Diego Pereira

Parents Reply Children
  • Hello,

    I used the command oainstall.sh -remove -agent and I was able to unisntall the version 12.XX and install the version 11.14.

    But I have a doubt, Is normal doesn't appear certificate in OVRG on VPV server? or I need to do something?

    [root@xxxxxxxxxx Agent]# ovcert -list
     --------------------------------------------------------- 
    | Keystore Content                                        |
     --------------------------------------------------------- 
    | Certificates:                                           |
    |     8ecd9140-7345-758a-0266-d100d50f756e (*)            |
     --------------------------------------------------------- 
    | Trusted Certificates:                                   |
    |     CA_4a89e8e3-2879-4972-b560-b6fe1d45ac2e_3456        |
     --------------------------------------------------------- 
    
     --------------------------------------------------------- 
    | Keystore Content (OVRG: server)                         |
     --------------------------------------------------------- 
    | Certificates:                                           |
     --------------------------------------------------------- 
    | Trusted Certificates:                                   |
     --------------------------------------------------------- 

    VPV appears to be working properly.

     

  • Didn't work, opcmona don't start and ovc is on version 12 yet.

     

    Probably We need to reinstall the entire application.

  • Verified Answer

    Hi, 

    You are right, the reinstallation of both CO and OA are required at this stage. Tthe ovc versions will not change, when you uninstall agent 12, the common binaries that are also used by CO are not unisntalled hence you will see ovc versions at 12 itself. I have not tested this myself so cannot comment on why opcmona is not working. I also understand there should be a co-ex support statement for CO 3 and Agent 12 soon.

    Cheers,

    Priya