Performance Manager 9.20 on OMW 9 Server

i have installed PM 9.20 on OMW 9 serever on 2008r2 sp1 OS

and it installed successsfully

but after reboot service OvEpMessageActionServer do not start.

Event Log shows several errors

 

(MS19) Error when starting up service. (MS428) Could not initialize NodeUpdateWriter ((ITF0E) Invalid OLEVERB structure ). (MS520) Failed to open node update queue. (MS136) IOvEpQueue::OpenInServerTempDir failed ((ITF0E) Invalid OLEVERB structure ).

 

if i change user under wich service run in event log i get this error

 

(MS1110) Error when starting up service. Unexpected failure during initialization of the server based flexible management ((NUL16389E) Unspecified error ). <null>

 

and follows error

 

Faulting application name: OvEpMsgActSrv.exe, version: 6.0.94.34, time stamp: 0x50f6e141
Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
Exception code: 0xc0000005
Fault offset: 0x00000000000532d0
Faulting process id: 0xbd4
Faulting application start time: 0x01cfbaca2fb29c97
Faulting application path: C:\Program Files\HP\HP BTO Software\bin\win64\OvEpMsgActSrv.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 7466c2cb-26bd-11e4-a3d6-005056917095

 

P.S. This thread has been moved from Systems Management (OpenView-OP Mgmt) Support and News Forum to OV Performance Management Forum. -HP Forum Moderator

Parents
  • Hello, I've had the same issue, after installing PM 9.20 on OMW 9, they both worked. But when rebooting server, then PM didn't run. Does any components of OM conflict with PM?
  • Verified Answer

    It seems that the OvShareDir setting in the registry settings gets corrupted when PM 9.20 is installed.

     

    this is 

    HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard\HP OpenView\ShareDir

     

    Please set the OvShareDir setting manually to the right folder - <OvDataDir>\Shared folder.

     

    Restart OMW services - that should fix your issue. 

    Not required generally, but you could reboot your system if services still do not start.

     

    The lab is aware of this issue and working on a fix. sorry about the inconvenience.

     

    - RamD

Reply
  • Verified Answer

    It seems that the OvShareDir setting in the registry settings gets corrupted when PM 9.20 is installed.

     

    this is 

    HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard\HP OpenView\ShareDir

     

    Please set the OvShareDir setting manually to the right folder - <OvDataDir>\Shared folder.

     

    Restart OMW services - that should fix your issue. 

    Not required generally, but you could reboot your system if services still do not start.

     

    The lab is aware of this issue and working on a fix. sorry about the inconvenience.

     

    - RamD

Children
No Data