"No Data" issue for Linux CPU Monitor in SiteScope

Hi All,

I have deployed monitoring for Linux Machine using template and all the monitors are polling data except CPU monitor for which the status is showing Green but it showing "No Data" os summary status. I tried deploying the CPU monitor separately for the same server but I'm getting the below error message

Error due to No Data : CPU Monitor on server failed : Exit code 67

Linux OS version - Red Hat Enterprise Linux ES release 4 (Nahant Update 5)

Please suggest your comments to fix the issue.

Thanks 
Mohammad Azarudeen

 

Tags:

Parents
  • Hello

    Can you please activate the debug for that specific monitor?, that way we can check further what is happening. Just go to monitor properties-->Logging settings tab, check the option "Enable separate log for this monitor", change the log level to "Debug", save the settings and run the monitor several times, this will create a log file under SiteScope\logs\monitor_runs folder (the log file has the same name as monitor), once done, please attach the log file here so we can analyze it.

    Regards,

    Allan D.

Reply
  • Hello

    Can you please activate the debug for that specific monitor?, that way we can check further what is happening. Just go to monitor properties-->Logging settings tab, check the option "Enable separate log for this monitor", change the log level to "Debug", save the settings and run the monitor several times, this will create a log file under SiteScope\logs\monitor_runs folder (the log file has the same name as monitor), once done, please attach the log file here so we can analyze it.

    Regards,

    Allan D.

Children
  • Verified Answer

    Perhaps you may want to re-create the remote server for this particular Linux target and recreate the CPU monitor once again after checking the manual/on-line help? For instance, one need install sysstat package on Linux target as prerequisites.

    CPU Monitor > Monitor Specific Troubleshooting/Limitations
    - If unable to monitor CPU usage on a Linux installation, check the sysstat package is deployed on the target Linux system.
    ..


    Also we hardly see Exit code 67  around Linux targets, while we sometimes see this error code of Windows OS when Windows is not able to find the target.

    C:\Users\Administrator>net helpmsg 67
    The network name cannot be found.

    Regards,