BSM cannot start after Monitoring Automation and User Engagement deinstallation

Hi,

I'm having BSM 9.24 (on Windos Server 2008 R2, 1GW 1DPS) and I tried to deinstall both Monitoring Automation and User Engagement.

First I disabled both MA and UE in server deployment and restarted BSM.

After restart I shutdown BSM and from Control panel Uninstalled both MA and UE.

After that when I tried to start BSM in wrapper.log I'm getting this error message:

STATUS | wrapper | 2016/01/11 15:15:42 | --> Wrapper Started as Service
STATUS | wrapper | 2016/01/11 15:15:42 | Java Service Wrapper Standard Edition 32-bit 3.5.15
STATUS | wrapper | 2016/01/11 15:15:42 | Copyright (C) 1999-2012 Tanuki Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2016/01/11 15:15:42 | http://wrapper.tanukisoftware.com
STATUS | wrapper | 2016/01/11 15:15:42 | Licensed to Hewlett-Packard Company for BSM
STATUS | wrapper | 2016/01/11 15:15:42 |
STATUS | wrapper | 2016/01/11 15:15:42 | Launching a JVM...
INFO | jvm 1 | 2016/01/11 15:15:55 | HttpAdaptor version 3.0.2 started on port 11021
INFO | jvm 1 | 2016/01/11 15:15:55 | WrapperManager: Initializing...
INFO | jvm 1 | 2016/01/11 15:15:55 | Exception in thread "nanny Manager:Initialize Task" org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [com.hp.opr.config.features.impl.SumCapacityStatusBean] for bean with name 'spiadv.CapacityStatusBean' defined in file [C:\HPBSM\conf\spring\spimp-license-spring.xml]; nested exception is java.lang.ClassNotFoundException: com.hp.opr.config.features.impl.SumCapacityStatusBean
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1141)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:524)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1177)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeanNamesForType(DefaultListableBeanFactory.java:222)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeansOfType(DefaultListableBeanFactory.java:303)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeansOfType(DefaultListableBeanFactory.java:297)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.context.support.AbstractApplicationContext.getBeansOfType(AbstractApplicationContext.java:941)
INFO | jvm 1 | 2016/01/11 15:15:55 | at org.springframework.beans.factory.BeanFactoryUtils.beansOfTypeIncludingAncestors(BeanFactoryUtils.java:224)
INFO | jvm 1 | 2016/01/11 15:15:55 | at com.mercury.infra.adapter.SpringManager.getListBeansByType(SpringManager.java:260)
INFO | jvm 1 | 2016/01/11 15:15:55 | at com.mercury.infra.nanny.manager.Main$InitializeTask.runValidators(Main.java:85)
INFO | jvm 1 | 2016/01/11 15:15:55 | at com.mercury.infra.nanny.manager.Main$InitializeTask.run(Main.java:109)
INFO | jvm 1 | 2016/01/11 15:15:55 | at java.lang.Thread.run(Thread.java:744)
INFO | jvm 1 | 2016/01/11 15:15:55 | Caused by: java.lang.ClassNotFoundException: com.hp.opr.config.features.impl.SumCapacityStatusBean
INFO | jvm 1 | 2016/01/11 15:15:55 | at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
INFO | jvm 1 | 2016/01/11 15:15:55 | at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
INFO | jvm 1 | 2016/01/11 15:15:55 | at java.security.AccessController.doPrivileged(Native Method)
INFO | jvm 1 | 2016/01/11 15:15:55 | at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
INFO | jvm 1 | 2016/01/11 15:15:55 | at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
INFO | jvm 1 | 2016/01/11 15:15:56 | at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
INFO | jvm 1 | 2016/01/11 15:15:56 | at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
INFO | jvm 1 | 2016/01/11 15:15:56 | at org.springframework.util.ClassUtils.forName(ClassUtils.java:211)
INFO | jvm 1 | 2016/01/11 15:15:56 | at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:385)
INFO | jvm 1 | 2016/01/11 15:15:56 | at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1138)
INFO | jvm 1 | 2016/01/11 15:15:56 | ... 11 more
STATUS | wrapper | 2016/01/11 15:23:49 | <-- Wrapper Stopped

How can I solve this problem?

Thanks,

Damir

  • Hello all,

    Thanks for the question,

    I would like to know the following:

    Do you have 1 DPS and 1 Gateway in the same box?

    Which order, do you follow to restar the BSM?

    Best Regards

     

     

     

  • Verified Answer

    Hi Juan.

    I have 2 separate VM machines.

    I had this problem only on DPS. Starting of GW was OK.

    I always follow the BP procedure of starting BSM. First DPS then GW.

    Also I managed to solve the problem.

    Solution was to remove file C:\HPBSM\conf\spring\spimp-license-spring.xml from this directory.

    Probably deinstall did not remove this file and those classes specified in file were removed. File was not present on GW server.

    Thank you for your help.

    Regards,

    Damir