[Support Tip] On several HP-UX servers after upgrade to 11.12 ver of OA Agent scopeux aborts



HP-UX 11.31 running 11.12 OA agent





We can see that midaemon is not running, but scopeux depends on it:



Perf Agent status:

WARNING: scopeux    is not active (Perf Agent data collector)

WARNING: midaemon   is not active (Measurement Interface daemon)



And in the log file for midaemon “status.mi”,  we can see the following error:



Start midaemon       11.11.025  2012-12-08_0031 HP-UX 11 =*=

midaemon: Tue Sep 10 11:48:35 2013

Unable to find newly enabled CPU.

Please use -prealloc to allocate bufsets for all CPUs.



This is the same issue as one CPE case in the labs. 





Workaround is to make midaemon allocate bufsets for all total number of CPUs configured.

For midaemon we have the following parameter:


-prealloc <value>

specifies the highest CPU ID the midaemon should pre-

allocate bufsets for. By default, bufsets are only allocated

for active CPUs, at startup time, and then dynamically as

CPUs become active. If the value provided as argument is

greater than the highest possible CPU ID, bufsets will be

allocated for all CPUs, present or not, active or not. This

was the default for previous versions of the midaemon. Note

that, when running the midaemon single-threaded, trace

buffers are pre-allocated regardless of this option.


Execute icapstatus, and verify the total number of CPU cores. Allocate bufsets based on the total number of CPU cores.

Explanation on setting -prealloc:

• allocate bufsets for total cpus using "midaemon -prealloc"

Example: # midaemon -prealloc= < Total number of Physical CPUS>

[ Here we need to use the Total number of Physical CPUS]

• So if any other midaemon options are already in use then add this option along with them like below:

If existing command is :

midameon -pids 10000 -kths 10000 -smdvss 512M

Then change it to:

midaemon -prealloc= < Total number of Physical CPUS> -pids 10000 -kths 10000 -smdvss 512M

If for example the Total number of Physicas CPUS on system is 8 the command will look like below:

midaemon –prealloc=8 -pids 10000 -kths 10000 -smdvss 512M

Steps to do it:

1) Stop Performance Agent (PA) using "/opt/perf/bin/ovpa stop"

2) Stop perfd using "/opt/perf/bin/pctl stop"

3) Check if any glance or , xglance running , then stop them all.

4) Check if still midameon is running , then stop it using "/opt/perf/bin/midaemon -T"

4) Check if midamon stopped, if not then its hanging. Kill it using "kill -9 <MIDAEMON PID>"

5) Edit PA start up script, /etc/rc.config.d/ovpa and add the following option,


MWA_START_COMMAND="/opt/perf/bin/mwa start"


MIPARMS="-prealloc=8 -pids 10000 -kths 10000 -smdvss 512M"

export MIPARMS

MIPARMS="-prealloc=<Total Number of Physical CPUs> -pids 10000 -kths 10000 -smdvss 512M"


if Total number of Physical CPUS is 8 then following is the way to set it.

export MIPARMS="-prealloc=8 -pids 10000 -kths 10000 -smdvss 512M"

export MIPARMS




6) Start PA using "/opt/perf/bin/ovpa start"

7) Start perfd using "/opt/perf/bin/pctl start"

8) Check 'ps -ef|grep midaemon' output of midameon to see whether midaemon is running with configured parameters.


PS: In Example the MIPARMS is based on the user values as explained above.