Error in osspi_chktab file (not creating) - Alarmdef file not creating

I'm having this same issue on multiple HP-UX 11.11 systems running the OVO agent and OVPA. I'm using OVOW to monitor this system.

I keep getting error messages like the ones listed below:

MeasureWare: Recreation of alarms failed
Node:
Message group: OSSPI-Internal
Application: HP OSSPI
Object: osspi_chkalarm.sh
Severity: Critical
Text: MeasureWare: Recreation of alarms failed

and

syntax error in osspi_alarmdef file
Node:
Message group: OSSPI-Internal
Application: HP OSSPI
Object: osspi_alarm_mw.sh
Severity: Major
Text: syntax error in osspi_alarmdef file

The contents of the directory is:

[/var/opt/OV/conf/osspi]
#ll
total 288
fsmon.cfg.chktab
harddisk.cfg
netif.cfg
opcagtinfo
osspi.cfg
osspi_alarmdef.chk
osspi_fsmon-hash.cfg
osspi_fsmon.cfg
procmon.cfg
syntax_gp
syntax_gp.old

Any Ideas?

Thanks,
Brandy

 

 

P.S. This thread has been moved from Systems Management (OpenView-OP Mgmt) Support and News Forum to OV Performance Management Forum - Hp Forum Moderator

Parents
  • On the HP-UX node, I went through the following steps to get the alarmdef file to update correctly:

    1. Killed the OVO agent. /opt/OV/bin/OpC/opcagt -kill

    2. Stopped the MWA agent. /opt/perf/bin/mwa -stop

    3. Deleted the osspi_alarmdef file. /var/opt/OV/conf/osspi/osspi_alarmdef

    4. Deleted the osspi_alarmdef.chk file. /var/opt/OV/conf/osspi/osspi_alarmdef.chk

    5. Removed all policies from the node in the management console except for
    OSSPI-alarmdef_write
    OSSPI-alarmwriteMsg
    OvSvcDiscErrorLog
    UNIX_OSSPI-AutoDiscovery
    UNIX_OSSPI-opcmsg

    6. Ran a opcagt -start. /opt/OV/bin/OpC/opcagt -start

    7. Ran a mwa -start. /opt/perf/bin/mwa -start

    8. Ran a opcagt -status (all processes are running)

    9. Ran a mwa -status (all process are running)

    10. Deployed OSSPI-MWA_Cpu_Load to the node through the management console

    11. Ran a cat osspi_alarmdef and the file had been updated correctly.

    12. Deployed other OSSPI-MWA policies and the osspi_alarmdef file updated correctly.

    13. Deployed the OSSPI-MWA_Filesystem policy and a major alert popped up in the management console:

    syntax error in osspi_alarmdef file

    Node:
    Message group: OSSPI-Internal
    Application: HP OSSPI
    Object: osspi_alarm_mw.sh
    Severity: Major
    Text: syntax error in osspi_alarmdef file

    I'm starting a new thread to work on the OSSPI-MWA_Filesystem policy issue.

    Thanks for all your help,
    Brandy
Reply
  • On the HP-UX node, I went through the following steps to get the alarmdef file to update correctly:

    1. Killed the OVO agent. /opt/OV/bin/OpC/opcagt -kill

    2. Stopped the MWA agent. /opt/perf/bin/mwa -stop

    3. Deleted the osspi_alarmdef file. /var/opt/OV/conf/osspi/osspi_alarmdef

    4. Deleted the osspi_alarmdef.chk file. /var/opt/OV/conf/osspi/osspi_alarmdef.chk

    5. Removed all policies from the node in the management console except for
    OSSPI-alarmdef_write
    OSSPI-alarmwriteMsg
    OvSvcDiscErrorLog
    UNIX_OSSPI-AutoDiscovery
    UNIX_OSSPI-opcmsg

    6. Ran a opcagt -start. /opt/OV/bin/OpC/opcagt -start

    7. Ran a mwa -start. /opt/perf/bin/mwa -start

    8. Ran a opcagt -status (all processes are running)

    9. Ran a mwa -status (all process are running)

    10. Deployed OSSPI-MWA_Cpu_Load to the node through the management console

    11. Ran a cat osspi_alarmdef and the file had been updated correctly.

    12. Deployed other OSSPI-MWA policies and the osspi_alarmdef file updated correctly.

    13. Deployed the OSSPI-MWA_Filesystem policy and a major alert popped up in the management console:

    syntax error in osspi_alarmdef file

    Node:
    Message group: OSSPI-Internal
    Application: HP OSSPI
    Object: osspi_alarm_mw.sh
    Severity: Major
    Text: syntax error in osspi_alarmdef file

    I'm starting a new thread to work on the OSSPI-MWA_Filesystem policy issue.

    Thanks for all your help,
    Brandy
Children
No Data