OpC20-401 error mgmt server new 8.0 install

I am receiving the following message for the OVOU mgmt server:

Can't run command /sbin/dmesg - > /var/opt/OV/log/OpC/dmesg.out. (OpC30-127)
no free slot in process-info-table (OpC20-401)

This makes no sense, "dmesg -" runs fine and the process table is only 7% utilized.

Messages repeats every 10 minutes or so
  • Verified Answer

    Donovan,

    Looks like a known problem documented in the HP document A4964652 ( http://openview.hp.com/sso/ecare/getsupportdoc?docid=A4964652 ) This document is related to ITO 4, but the same problem exist will all newer release.

    The fix is to set the variable MAX_NBR_PARALLEL_ACTIONS to a value greater than the default value of 10.

    with OVO 8, the variables are no more set in the opcinfo/opcsvinfo files. On the agent reporting the error, use the command ovconfchg -edit and add a line :
    MAX_NBR_PARALLEL_ACTIONS=
    in the [eaagt] section, then restart the OVO agent.

    Extract from the HP document describing the error :
    PROBLEM


    I'm trying to run a script on my box that fixes a mail
    problem when a message comes in and then it executes an
    automatic action. This action spawns off a script that
    is executed until the problem is fixed. When ITO spawns
    off 11 actions and the first 10 are still executing, I
    notice that the 11th script does not get started.

    How do I run the 11th script (more than 10)?

    CONFIGURATION


    Operating System - HP-UX
    Version - 10.10
    Hardware System - HP 9000
    Series - K200

    RESOLUTION


    Note that in some instances, the following error message occurs
    as a result of this symptom:

    no free slot in process-info-table (OpC20-401)

    To correct the problem, increase the number of processes ITO can
    run when trying to run a script on a managed node by putting
    these lines in /opt/OV/bin/OpC/install/opcinfo:

    MAX_NBR_PARALLEL_ACTIONS

  • Really, this has been around since version 4.x?

    I've had all the vesions since then and can not remember this problem. My old opcinfo and opcsvinfo file did not have the MAX_NBR_PARALLEL_ACTIONS parameter anywhere.
  • Donovan,

    I also rarelly use this variable, only on two agents with a high number of monitors assigned.


    As it's related to the number of monitors, actions running simultaneously and OVO 8 tend to use more CPU ressources than previous release may be you just hit the limit of 10.

  • How high are people going  for that varuiable value, before seeing the message disappear, is there an upper limit?