Script created in BSM not appearing in BPM

Hello All

APM 9.30
BPM 9.30.471

We had created new script using vuGen to monitor an web based application and added the script in script repository in BSM. We further created End User Monitor in BSM and launched the script in BPM. However we see the script is not running in BPM.

We further checked in BPM and in BPM also we are not seeing the script been listed.

Please provide your help to fix this issue.

  • please check out in the BPM logs if you see any errors

    you can find it under %programData%\HP\BPM\workspace

    You can stop BPM delete workspace and restart it just to see if this is a temp problem or not.

  • In BPM Workspace, I see following error under details section

    440 - Failed to register

    Please clarify what does it mean and how to solve it.

  • so from the logs below I noticed you have a RSHEL platform. please note BPM can run only HTTP/WEB scripts in such operating system. 

    If you are using a HTTP/WEB protocol that please run the script manual from the workspace using a simple command line 

    The way to run it, is to browse to the script\RES folder open . Open the file cmdline.txt copy the content and run it using your own user. check the output.log results immediately after the run.


  • Hi

    I ran the script and checked the file output.txt and it contains following error,

    vuser_init.c(75): Error -27794: Could not resolve address of host       [MsgId: MERR-27794]
    Vuser Terminated.

    I had faced this issue in vuGen when I try to replay the script and I solved it in vuGen by defining Proxy in script properties.

    I then imported the script as ZIP file and imported it in BSM and then launched in BPM.

    However I am seeing the same error as received in vuGen.

    Do I need to define any proxy at BSM/BPM level to resolve this issue.

  • It depends which proxy option you used in your script. for the testing I suggests you just use the "Use custom proxy" option in your script "replay"-> "runtime setting" -> "proxy" options

    If you did so that it should work.

    Now - regarding the DNS error, it is simply because BPM can not resolve this specific address. I suggest to check if it works manually without the script. 

    Just login to the machine and ping to this URL ("ping") , if you get the same problem and you dont get the IP than you need to fix you machine and setup a DNS client to be able to resolve this URL. 

    form my experience there is almost not DNS issue for a script without having the same problem from the machine without the script.


  • Hi

    I configured "Use custom proxy" option in my script "replay"-> "runtime setting" -> "proxy" options, but it fails with error,

    vuser_init.c(12): Error -26609: HTTP Status-Code=503 (Service Unavailable) for ""      [MsgId: MERR-26609]

    I then configured "Use the default HTTP proxy settings" and then replay got succeeded.

    Coming back to the issue of running the script in BPM, I see ping fails, so I added entry in /etc/hosts file to resolve it.

    But now I am seeing one more error,

    Error -27794: Could not resolve address of host

    By the way I see vuGen is inserting additional URL like above which is causing this issue.

    How to rectify it.


  • Hi

    I created new vuGen script using IE and uploaded it to BSM and launched it from BPM.

    From /opt/HP/BPM/workspace/agent1/Site1/ops__________5e490adcdf3f8d571d97c29a879e93a5_1/WebHttpHtml1/21_1/output.txt, I am seeing following lines,

    Action.c(1036): web_url("logout.24.gif_2") was successful, 13610 body bytes, 171 header bytes   [MsgId: MMSG-26386]
    Ending action Action.
    Ending iteration 1.
    Ending Vuser...
    Starting action vuser_end.
    Ending action vuser_end
    Vuser Terminated.

    which I assume the script was executed successfully.

    In /opt/HP/BPM/workspace/agent1/Site1/ops__________5e490adcdf3f8d571d97c29a879e93a5_1/WebHttpHtml1/21_1/res/output.txt, I am seeing following error

    Action.c(4): Error -27724: Step download timeout (120 seconds) has expired      [MsgId: MERR-27724]

    How to solve this.

  • so Step download timeout (120 seconds) has expired meaning your URL was nto accesible form the BPM machine.

    You can just put this URL in the BPM machine browser  and check it is happen there.

    This is a simple timeout message not a script issue.

  • Noam

    Does it mean I need to open FW ports from BPM Server to the URL requested in the script.

  • Hi

    Yes I am able to access the URL from my BPM server.

    If I look at output.txt, I am seeing following,

    Vuser Terminated.

    If I look at /opt/HP/BPM/workspace/logs/bpm_all.log, I am seeing following errors,

    WARN  [BpmTaskRunner-17] [GeneralScriptTaskExecutor] The script output file: WebHttpHtml1_*.json.cp was not created. Setting the exit code to: 6

    ERROR [SamplesHandlerThread (Site1)] [ScriptMetadata] transactions metadata is missing in metadata file: /opt/HP/BPM/workspace/agent1/Site1/data/trans_t/1491109049001_643/1491109049000_1_21_WebHttpHtml1/WebHttpHtml1.metadata samples will not be sent for this script run.

    What does it mean and how to solve it.


  • It can be due to many reasons but in your case I think you did not wrap the script with a transactions (start transaction and end transaction), hence the script exist with status  6 (script error) since it does not have a transaciton to report this error.

    send me the script to review.

  • Noam


    Not able to attach the file as .usr or .zip, hence attached in image format.

Reply Children
No Data