SQL SPI message - database not backed up for 876000 hours (but it HAS been!)

 

Hi,

 

Using the SQL SPI on OML9 - normally works fine, but for a couple of SQL databases we get this error:

 

Database Model NOT BACKED UP for 876000 hours.

 

Our thresholds are only set to 24hrs, and the message text would state that, so the SPI seems to be getting this value of 876000 from somewhere.

 

The database I have been assured has been backed up, so the SPI is either not getting the right information, or it can't access the information and is defaulting to this value (100 years).

 

Any ideas what's wrong?

 

For the moment I have put in a threshold to catch this and suppress it, but this means the monitor might not be working at all for this database, so a solution would be better!

 

Thanks,

Dave

Parents
  • Verified Answer

    Hello David,

     

    876.000 is indeed the default value for databases which have not been backed up. To check whether this would indeed be appropriate for your model database, could you check with the following query:

     

    select * from from msdb..backupset;

     

    Thank you,

    Uli

     

     

Reply
  • Verified Answer

    Hello David,

     

    876.000 is indeed the default value for databases which have not been backed up. To check whether this would indeed be appropriate for your model database, could you check with the following query:

     

    select * from from msdb..backupset;

     

    Thank you,

    Uli

     

     

Children