BSM 9.25 DB connection problem

For some reason we migrate our Oracle DB to the new server. We got follow problem: our Oracle server is set to minimum client version as 11, but BSM 9.25 client connection version is 8.  Is it possible to set client version for mercury oracle driver or get newer version or such driver? Oracle admins doesn't want to downgrade client connection version ...