Get Job Failed for BPM 9.22

Hi All,

We have installed BPM 9.22 version in the Windows server 2008 R2 64 bit OS.

Installation completed successfully but when we try to create BPM instance page it shows the health as "Get Job Failed"  Error in a getJob response.

Please find the attached screenshot.

Thanks,

Rams

 

 

 

Parents
  • Hi Rams,

    Have you created a profile database yet, and also made it the default profile database?

    Can you share a screenshot of the configuration tab from the BPM web console to show the connection settings?

    Regards,
    Tim

  • Hi Tim,

    Please find the attached BPM instance config settings.

    Thanks,
    Rams

  • Hi Rams,

    Here are a few things to check:

    Can you connect to the BSM URL from a browser on the BPM machine?

    Can you see any errors in the logs on the BPM Probe?  The logs are usually located here:

       C:\ProgramData\HP\BPM\workspace\logs\

    Do you have other working BPM Probes, or is this the first one?  Is this a new BSM environment?

    Can you see the BPM Probe in BSM / Admin / End User Management / Settings / Business Process Monitor Settings / BPM Agents?  Can you launch the BPM web console from here?

    Regards,

    Tim

  • Hi Tim,


    Yes I am able to connect BSM URL from the BPM machine.


    Please find the below errors from workspace folder


    workspace\agent1\agent_Site1 :  WARNING Cannot restore job from file 'D:\HP\BPM\workspace\agent1\Site1\model_persistency_job.xml': file

    workspace\bpm_admin_out: Failed to connect to the bpm. Next try in one second.

    workspace\topaz_agent_manager: Error: Communication error: Linked List client failed to initialize server pointer.

    workspace\topaz_agent_manager_launcher: [Launcher] Failed to create custom channel client on main thread(connection string: (-server_type=6)(-guid_identifier=MTzSBXe8lkGLmJQXIFSkOg==)(-ll_server_index=6)).

    workspace\agent1\agent1_drvlog: Warning: Failed init user token for user  , system error: The parameter is incorrect.
    . [MsgId: MWAR-29794]

    We have other couple of BPMs which are running fine (of the same version 9.22).


    Somehow I dont see any BPM probes at the below path.


    BPM Probe in BSM / Admin / End User Management / Settings / Business Process Monitor Settings / BPM Agents?

     

    Thanks,

    Rams

  • Hi Rams,

    I can see an initstring error and I think that may be the problem.  Can you check the initstring value of this BPM probe and compare it with the initstring value of the working BPM Probes?  This can be found in the following file on the BPM Probes:

       <BPM installation directory>\ServletContainer\webapps\ROOT\WEBINF\classes\lwssofmconf.xml

    If the value is different on the working BPMs, try updating it in lwssofmconf.xml on the failing BPM Probe, then restart it.

     

    The last line in my previous post was to check if the BPM has registered in BSM.  The screen should look like the attached image.

    Regards,

    Tim

     

     

  • Hi Tim,

    Initstring value is empty for all the BPM machines(working and failed).

    <cr<crypto paddingModeName="CBC" keySize="256" initString="" engineName="AES" encodingMode="Base64Url" directKeyEncoding="Hex" directKeyEncoded="false" cipherType="symmetricBlockCipher"/>

    I have installed this BPM 9.22 version very recently but the lwssofmconf.xml file looks very old file.

    Thanks,
    Rams

     

  • Hi Rams,

    Did this server have a previous version of BPM installed?  If so, it's possible that it did not fully uninstall.

    Have you tried a full uninstall and reinstall (selecting 'run as admininstrator' when launching the installer)?

    Regards,

    Tim

  • Hi Tim,

    Yes, the server had BPM 9.24 version.

    I uninstalled it and installed 9.22 (selected 'run as admininstrator').

    With BPM 9.24 version, profiles not etting reflcted in BPM admin page.

    Thanks,

    Rams 

  • Hi Rams,

    Do you have any other HP software on this BPM (other than standard HP server tools if the BPM is an HP branded server)?  If so, make sure they are completely uninstalled, and then try a re-install, running as administrator again, and ensuring UAC is disabled (User Account Control).

    Does this have the same Java client version as your other BPMs?  This is only applicable if you are connecting to the BPM admin page from a browser on the BPM machine itself.

    Have you seen this post?  It's worth considering Siggi's advice unless there's a specific reason why you need v9.22:

    http://community.hpe.com/t5/Application-Perf-Mgmt-BAC-BSM/BPM-9-24-installation-Error/td-p/6643438

    Regards,

    Tim

Reply Children
No Data