Change number of open files for opcuiwww


Running OML 9.21 on Centos 6.8. We have soft and hard limits in /etc/security/limits.conf to 65000 for all users. However, opcuiwww.ldap shows a limit of 4096 (when looking at /proc/<pid>/limits). Is there a way to get opcuiwww.ldap to start up with a higher limit? '

Thanks for any input.


  • Do you see any "ulimit -n" commands in any scripts?

  • Dennis,

    Thanks for your reply. 

    I don't see anywhere that ulimit -n is set. I would have expected to (maybe) see something in but nothing in there seems to modify the number of open files. 


  • Hello Bob,


    4096 is plenty and should be high enough for opcuiwww.

    But anyway, opcuiwww is started by inetd (xinetd on Linux) and thus inherits the limits for inetd/xinetd. If you want to have a higher limit, you can edit, for example after following lines:

    echo "`date ' %a %b %d %H:%M:%S %Y'`: OVO server processes up and running - starting opcuiwww" >> ${LOGFILE}
    cd /tmp # don't mix up cores from opcuiwww and other OVO processes

    You could add these lines:

    # Set ulimits for the process ...
    ulimit -c 2097152 # Core file size: 2G (disabled by default)
    ulimit -n 65000 # Number of open files (1024 by default)

    Note, that OM server patches may overwrite and you will need to re-apply this change.

    Best regards,


  • Tobias, 

    Thanks very much for your reply. I'll give that a try in Also, looks like there is an rlimit_files setting in xinetd.conf that I can try. I'll give them both a try and report back.

    Thanks again,


Reply Children
No Data