UCMDB Reconciliation Error

Hello Expert, We are using RTSM UCMDB 9.04 with CP6, started getting the below error in cmdb.reconciliation log while relating business service with switch/router, please let us know what could be the problem. Pop-up "Identification map is larger than the defined maximal size. Check reconcilliation log for more details" cmdb.reconciliation.log at com.hp.ucmdb.reconciliation.data.IdentificationMapImpl.checkMapSizeFuse(IdentificationMapImpl.java:157) at com.hp.ucmdb.reconciliation.data.IdentificationMapImpl.append(IdentificationMapImpl.java:118) ... 84 more 2015-10-21 12:22:23,077 DEBUG - [Operation #1665677076 Name=DataInUpdateDataIfExist] **********************************************************
Parents
  • Verified Answer

    Hi Shivshankar Yadav_1,

     

    the error message tells you what the issue is:

     

    "Identification map is larger than the defined maximal size. Check reconcilliation log for more details"

     

    As the popup tells you, the identifaction map is larger than the maximum size.

    I found various cases with this error message in SSO, you should even be able to see the current limit in one of the logs:
    ..
    com.hp.ucmdb.reconciliation.datain.operation.DataInOperationException: [ErrorCode [63010] Identification map total size is larger than the defined fuse.{20000000}]
    ..
    but perhaps the more detailed message only was introduced in a newer version of BSM, 9.12 is quite old, and you definitely need to consider an upgrade.

     

    You might wanna double the size by accessing the uCMDB JMX

    http://<DPS>:21212/jmx-console/
      UCMDB
        UCMDB:service=Settings Services
          setSettingValue
            customerID : 1
            name       : reconciliation.identification.map.fuse
            value      : 40000000
    click Invoke

     

    You should get back a message like

     

    Mbean: UCMDB:service=Settings Services. Method: setSettingValue
    Setting [reconciliation.identification.map.fuse] value changed seccessfully to [40000000]

    then the change was successful.

     

    Greetings

    Siggi

  • Thanks and appreciate your support, your solution helped in resolving the issue.
Reply Children
No Data