BSM cannot connect to Oracle 12c

Hi All!

 

We had a migration of the DB from Oracle 11.2 to 12c

Since then our BSM is down:

[mercury][Oracle JDBC Driver][Oracle]ORA-28040: No matching authentication protocol

 

It seems that we can connect to Management DB but not to RTSM,  maybe an issue with the jdbc connector?

 

I hope someone can help.

 

Thanks!

 

 

Parents
  • Verified Answer

    Hi Twinge,

     

    I experienced this issue last week when I upgraded a system from 8.07 to 9.24 IP1.

     

    It seems that BSM uses a way to connect to Oracle 12c which by default is not supported by the DBMS.

    To work around this issue, there is one option only:
    you need to tell Oracle that it also allows connection requests using the old (pre Oracle 11) style of authentication:

    In 12.1, the default value for the SQLNET.ALLOWED_LOGON_VERSION parameter has been updated to 11. This means that database clients using pre-11g JDBC thin drivers cannot authenticate to 12.1 database servers unless the SQLNET.ALLOWED_LOGON_VERSION parameter is set to the old default of 8.

    So you / your DBA would need to set
     SQLNET.ALLOWED_LOGON_VERSION=8
    in the oracle/network/admin/sqlnet.ora file,
    then it should work.

    Greetings
    Siggi

Reply
  • Verified Answer

    Hi Twinge,

     

    I experienced this issue last week when I upgraded a system from 8.07 to 9.24 IP1.

     

    It seems that BSM uses a way to connect to Oracle 12c which by default is not supported by the DBMS.

    To work around this issue, there is one option only:
    you need to tell Oracle that it also allows connection requests using the old (pre Oracle 11) style of authentication:

    In 12.1, the default value for the SQLNET.ALLOWED_LOGON_VERSION parameter has been updated to 11. This means that database clients using pre-11g JDBC thin drivers cannot authenticate to 12.1 database servers unless the SQLNET.ALLOWED_LOGON_VERSION parameter is set to the old default of 8.

    So you / your DBA would need to set
     SQLNET.ALLOWED_LOGON_VERSION=8
    in the oracle/network/admin/sqlnet.ora file,
    then it should work.

    Greetings
    Siggi

Children