SiteScope - the File Monitor configuration

Can somebody advise please?

 

SiteScope 11.24

 

What should be the content of the

  • “Server” and
  • “File Name”

fields in the File Monitor configuration?

 

The monitored “TestFile.txt” file is located on a remote Windows server (not the SiteScope server):

\\RemoteSvr1\SharedFolder\testfile.txt

 

The “SharedFolder” on the “RemoteSvr1” server is shared out to the account under which the SiteScope service runs (read access).

Despite that the connection to the RemoteSvr1 server is configured in the SiteScope “Remote Servers”, this server does not appear in the pick list of the “Server” (the remote server is a Windows server).
The connection in the “Remote Servers” to the RemoteSrvr1 server tests good for each type of connection (NetBIOS,  WMI or SSH).
I am getting the error message \\RemoteSvr1\SharedFolder\testfile.txt not found no matter which connection method I use.

 

Please advise.

Thank you.

Gerard

Parents
  • Update.

    I would like to modify my question and refer in it only the NetBIOS type of connection
    (I found out that WMI type of connection cannot be used by the File Monitor and my SSH connection needs some work).

    Thank you.

    Gerard

  • You use absolute path "C:\file.txt" if you select the target server in the Server list. If you select SiS server you use the Windows shared path such \\remote_server\C$\file.txt

     

    Notice the shared folder should have read permissions for SiS service account if it's not Local system.

  • Kenneth,

     

    Thank you very much for taking time to answer my question.

     

    The target server does not appear in the Server list (because, if I understand correctly the documentation, for this monitor only UNIX servers appear in that list). So I have to select the SiS server in that field.

     

    Following your advice, I put

    \\RemoteSvr1\SharedFolder\testfile.txt

    in the File Name field but I received the same original eror message.

     

    Yes, the share folder (ShareFolder) does have read permission for the account under which the SIteScope run and uses to access that testfile.txt.

     

    Should my path be constructed differently?.

     

    Thank you again.

    Gerard

     

     

     

  • You're right, this was changed in 11.x and you can't select Windows servers anymore. Your path seems OK , can you open that file if you type that path in Windows Explorer in SiS server?

  • You're right, this was changed in 11.x and you can't select Windows servers anymore. Your path seems OK , can you open that file if you type that path in Windows Explorer in SiS server?

  • You're right, this was changed in 11.x and you can't select Windows servers anymore. Your path seems OK , can you open that file if you type that path in Windows Explorer in SiS server?

  • Kenneth,

     

    I am unable to verify the "can you open that file if you type that path in Windows Explorer in SiS server?" because the account under which the SiS service is running is not allowed to make a remote connection to this SiS server.  Also, while logged with the admin account to that server the option to run IE as a "different user" is not available.

     

    The only test I could complete on the SiS server was to map that "SharedFolder" located on the "RemoteSrvr1" as a network drive using the user that SiS service is running on. After I mapped it I was able to access the "testfile.txt" as that user.

     

    I recreated the shared folder on the remote server and the test file. I shared out them again to the account SiS service is running giving Admin permissions (the SiS account is in the local Admin group on the remote server" still the sitescope "File Monitor" give me the "\\RemoteSvr1\SharedFolder\testfile.txt    not found" error.

     

    I noticed that if I use the ip address of the remote server or its short name, I still get the same error message but the Status column in the Monitor History shows green "up and down" arrows indicating that the connectioni to server was made (?). If I use the fully qualified server name these arrows are red.

     

    Would you have any advice on the next step to get this working?

     

    Thank you again.

    Gerard

     

     

  • Try opening a command prompt in SiS server then run these commands:

     

    Delete network passwords for shared resources: net use * /DELETE

     

    Connect to shared folder: net use \\RemoteServer\Shared

    Enter SiS account credentials

    Check the file: dir \\RemoteServer\Shared\file.txt

     

Reply Children
  • Verified Answer

    I completed

     

    -    Delete network passwords for shared resources: net use * /DELETE

     and

    -     Connect to shared folder: net use \\RemoteServer\Shared

     

    I am not sure how to go about doing this ?     "Enter SiS account credentials"

     

    So I ran this command using my own (admin) account

    Check the file: dir \\RemoteServer\Shared\file.txt - this generated the error "file not found"

     

    so, I ran dir \\RemoteServer\Shared and the response was:

     

    testfile.txt.txt

     

    (with two txt entensions). So I entered the "testfile.txt.txt" into the file path in the monitor configuration and it completed succesfully!!    It took about 10 secs to complete but it did not fail.

     

    This is very interesting.

    I am not sure why the file has two "txt.txt" extensions.

     

    Thank you for helping.

     

    Gerard

  • Kenneth,

     

    It looks that whenever we create a text file on the Windows server the system will automatically add its own extension (.txt). That means that should name the file without the extention - just "TestFile".

     

    I woudl ike to thank you again for helping me.

    Thank you.

    Gerard

  • You're welcome. Intresting, maybe is that Windows 2008 feature that hides known extensions?