BSM 9.10: Error when trying to log into BSM

Hello,  

 

I am getting the below error from IIS.   I have checked everything on the Microsoft website for the article on this error. 

 

HTTP Error 500.0 - Internal Server Error Calling LoadLibraryEx on ISAPI filter "I:\HPBSM\bin\IIS\isapi_redirect.dll" failed

 

Does anyone have a clue as to hpow to resovle this or seen this with BSM 9.10 and IIS 7.5?

 

Any information greatly appreciated.

 

Thanks.

Parents Reply Children
  • Rajeskare,

     

    Here are the supervisor log files attached.

     

    Let me know what you find.

     

    Thanks.

  • I don't see any issues on BSM side and there is no information about attaching to IIS. Have you tried re-installing IIS? Can you try again running the batch files manually from command prompt & provide the output?

    See the application/system event logs for any error information for IIS. One way to verify if your IIS is working fine is to remove topaz at the end BSM URL and open it in a browser. You should get "It Works" message.

    Just wondering if this is an upgraded environment from BAC 8.x to BSM 9.10 environment? If so, there is a bigger issue that need to be addressed.

    On the other note, is this a single server deployment & your DB installed on same server?
  • I don't see any issues on BSM side and there is no information about attaching to IIS. Have you tried re-installing IIS? Can you try again running the batch files manually from command prompt & provide the output?

    See the application/system event logs for any error information for IIS. One way to verify if your IIS is working fine is to remove topaz at the end BSM URL and open it in a browser. You should get "It Works" message.

    Just wondering if this is an upgraded environment from BAC 8.x to BSM 9.10 environment? If so, there is a bigger issue that need to be addressed.

    On the other note, is this a single server deployment & your DB installed on same server?
  • Looks to me like there was an upgrade and IIS settings (path to isapi_redirect.dll) have not been updated properly during the upgrade, causing access to BSM Gateway server to fail with HTTP error.

     

    The IIS configuration needs to be changed (via IIS applet in Windows) to reflect the new updated path.


    Can you try this, stop BSM services and on GW execute the following

     

    In the example below BAC 8.07 was installed in D:\HPBAC, BSM 9.12 was installed to D:\HPBSM,
    So the path needs to be changed from "D:\HPBAC" to "D:\HPBSM"

    start
     Internet Information Services (IIS) Manager
    on the left pane select
     <BSM_GW_host>
      IIS
    on the right pane click on
        ISAPI Filters
          Filter name : jakartaFilter
          Executable  : D:\HPBSM\bin\IIS\isapi_redirect.dll

    on the right pane click on
        ISAPI and CGI Restrictions
          ISAPI or CGI path : D:\HPBSM\bin\IIS\isapi_redirect.dll
          Description       : jakartaFilter
          Allow extension path to execute : checked

     


    --Sujith

  • Rajasekhar,

     

    IIS has not been reinstalled as it has been working prior to BSM isntall.

     

    I ran the batch scripts again and outputs are attahced.

     

    I can see IIS 7 is working fine and says "It works"

     

    No this is not an upgraded environment. This is a new clean install on W2K8 Server.

     

    This is a single server deployment.

     

    Also, I got this error after running the iisconfig.bat script:

     

     

    I:\HPBSM\dat>iisconfig.bat
    log4j:WARN No appenders could be found for logger (com.mercury.infra.utils.logge
    r.LogFactory).
    log4j:WARN Please initialize the log4j system properly.

     

    Thanks.

  • Rajasekhar,

     

    IIS has not been reinstalled as it has been working prior to BSM isntall.

     

    I ran the batch scripts again and outputs are attahced.

     

    I can see IIS 7 is working fine and says "It works"

     

    No this is not an upgraded environment. This is a new clean install on W2K8 Server.

     

    This is a single server deployment.

     

    Also, I got this error after running the iisconfig.bat script:

     

     

    I:\HPBSM\dat>iisconfig.bat
    log4j:WARN No appenders could be found for logger (com.mercury.infra.utils.logge
    r.LogFactory).
    log4j:WARN Please initialize the log4j system properly.

     

    Thanks.

  • Rajasekhar,

     

    IIS has not been reinstalled as it has been working prior to BSM isntall.

     

    I ran the batch scripts again and outputs are attahced.

     

    I can see IIS 7 is working fine and says "It works"

     

    No this is not an upgraded environment. This is a new clean install on W2K8 Server.

     

    This is a single server deployment.

     

    Also, I got this error after running the iisconfig.bat script:

     

     

    I:\HPBSM\dat>iisconfig.bat
    log4j:WARN No appenders could be found for logger (com.mercury.infra.utils.logge
    r.LogFactory).
    log4j:WARN Please initialize the log4j system properly.

     

    Thanks.

  • you are getting it works message without topaz

     

    Can you provide screenshot of error you are getting while accessing bsm url ?

  • I hope you have followed this during initial IIS configuration, if not please stop BSM & do this.

    If you are installing on a Microsoft Windows Server 2008 and using the IIS 7.X Web server, you must perform the following procedure:
    1 In the Control Panel, select Administrative Tools > Server Manager.
    2 Right-click Roles and select Add server role to launch the Add Roles wizard.
    3 On the Select Role Services page, select Web Server (IIS) role to install.
    If a popup opens with the question Add features required for Web Server (IIS)?, click the Add required features button.
    4 Click Next twice.
    5 In the Select Role Services panel, select the following roles:
    ➤ Application Development section: ISAPI Extensions and ISAPI Filters.
    ➤ Management Tools section: IIS Management Scripts and Tools
    6 Click Install.

  • I hope you have followed this during initial IIS configuration, if not please stop BSM & do this.

    If you are installing on a Microsoft Windows Server 2008 and using the IIS 7.X Web server, you must perform the following procedure:
    1 In the Control Panel, select Administrative Tools > Server Manager.
    2 Right-click Roles and select Add server role to launch the Add Roles wizard.
    3 On the Select Role Services page, select Web Server (IIS) role to install.
    If a popup opens with the question Add features required for Web Server (IIS)?, click the Add required features button.
    4 Click Next twice.
    5 In the Select Role Services panel, select the following roles:
    ➤ Application Development section: ISAPI Extensions and ISAPI Filters.
    ➤ Management Tools section: IIS Management Scripts and Tools
    6 Click Install.